[CentOS] Re: [users] Mrepo (with Redhat) works on one but not the other?

Camron W. Fox cwfox at us.fujitsu.com
Sat Mar 10 01:08:55 UTC 2007


Matt Hyclak wrote:
> On Fri, Mar 09, 2007 at 01:59:08PM -1000, Camron W. Fox enlightened us:
>> Jim Perrin wrote:
>>> On 3/9/07, Camron W. Fox <cwfox at us.fujitsu.com> wrote:
>>>
>>> <snip>
>>>
>>>> rhnget: "Unknown error that needs more debugging occured with channel
>>>> rhel-x86_64-es-4-extras. Skipping.\n'up2date'"
>>>> mrepo: Mirroring failed for rhns:///rhel-x86_64-es-4-extras with message:
>>>>
>>> Look at url string, rhns:///
>>>
>>> I don't think that looks right. You might wish to check the
>>> corresponding versions of all software involved. I'm not 100% where
>>> it's pulling that value, but it may give you a place to start looking.
>>>
>>>
>> Jim,
>>
>> 	It's straight out of /etc/mrepo.conf.d/rhel4es.conf, which is the 
>> 	same on both boxes:
>>
> 
> What version of mrepo? There was a problem at one time where rhns:///
> evaluated to something that came from the up2date configuration, which on a
> CentOS box was not a redhat rhn server (go figure...).
> 
> You might check that, as well as making sure the the line 
> 
> up2date default
> 
> is uncommented in /etc/sysconfig/rhn/sources
> 
> It is commented by default on CentOS boxes and is required for mrepo to work.
> 
> Matt
> 
Matt,

	D'Oh!!! I forgot to uncomment the "up2date default" line in 
/etc/sysconfig/rhn/sources! Thanks for showing me the obvious.

Best Regards,
Camron


Camron W. Fox
Hilo Office
High Performance Computing Group
Fujitsu America, INC.
E-mail:		cwfox at us.fujitsu.com




More information about the CentOS mailing list