[CentOS] Samba config for Windows on VMWare

Mark Schoonover schoon at amgt.com
Fri Mar 23 19:24:15 UTC 2007


 

From: Mark Hull-Richter [mailto:mhull-richter at datallegro.com]
Sent: Friday, March 23, 2007 12:15 PM
To: CentOS mailing list
Subject: [CentOS] Samba config for Windows on VMWare



I know this is a little off topic (not as usual, dammit!), but I figure at
least one of y'all can handle this one.

 

I have tried to configure my CentOS4.4 Plus desktop for samba sharing with
the VMWare Windows that runs on it.  However, no matter what I've done so
far, I can't get the Windows to recognize this machine as a legitimate
network destination.

 

Here's my samba config file:

 

[root at mhullrichter shared]# cat /etc/samba/smb.conf

# Global parameters

[global]

        server string = Samba Server

        security = SHARE

        log file = /var/log/samba/%m.log

        max log size = 50

        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

        printcap name = /etc/printcap

        dns proxy = No

        idmap uid = 16777216-33554431

        idmap gid = 16777216-33554431

        cups options = raw

 

[homes]

        comment = Home Directories

        read only = No

        browseable = No

 

[public]

        comment = Data

        path = /home/mark

        force user = mark

        force group = users

        read only = No

        guest ok = Yes

 

[printers]

        comment = All Printers

        path = /var/spool/samba

        printable = Yes

        browseable = No

 

It passes testparm, the smb daemons are up and running:

 

[root at mhullrichter shared]# psg smbd

root      2751     1  0 11:44 ?        00:00:00 smbd -D

root      2752  2751  0 11:44 ?        00:00:00 smbd -D

 

I noticed that neither the nmbd nor winbindd daemons are running - dunno
why, the startup showed [ OK ].

 

But in the Windows, it can see my machine but can't connect to it - what am
I missing?

 

Mark Hull-Richter         Linux Kernel Engineer
(949) 680-3082 - Office     (949) 680-3001 - Fax     (949) 632-8403 - Mobile
 <mailto:mhull-richter at datallegro.com> mhull-richter at datallegro.com
 <http://www.datallegro.com> www.datallegro.com

 Mark,

 

    Have you added the samba workstation to your domain/workgroup?? I don't
see any security settings in your conf file.

HTH


 

Thanks!

Mark Schoonover *** Winner of the 2008 Best Psychic Award
IS Manager
American Geotechnical - California, Nevada and Arizona
V-> 858.450.4040 F-> 714.685.3909 C-> 858.472.3816 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20070323/7a5079f1/attachment.htm


More information about the CentOS mailing list