[CentOS] libgd question on CentOS (in order to get PerfParse working with Nagios)

Rogelio scubacuda at gmail.com
Wed Nov 28 21:05:58 UTC 2007


Do I have the necessary gd packages installed on my CentOS 4 box?

rpm -qa | grep gd

gdk-pixbuf-0.22.0-17.el4.3
gdk-pixbuf-devel-0.22.0-17.el4.3
gdbm-1.8.0-24
gdbm-devel-1.8.0-24
gd-devel-2.0.28-5.4E
gd-2.0.28-5.4E
gdm-2.6.0.5-7.rhel4.15
sysklogd-1.4.1-26_EL

I'm trying to install PerfParser (./compile->make && make install),
but I'm getting a "gImageString error", which according to this FAQ
(http://perfparse.de/tiki-view_faq.php?faqId=1) means:

"The gd library is probably not installed yet on your system. Or you
are missing the development package such as libgd-devel or libgd-dev."

I "yum search" 'd for libdg and found the following.  Is this what I install?

libgdiplus.i386                          1.0.5-1.2.el4.rf       rpmforge
Matched from:
libgdiplus
libgdiplus is an Open Source implementation of the GDI+ API, it is part
of the Mono Project


libgdiplus-devel.i386                    1.0.5-1.2.el4.rf       rpmforge
Matched from:
libgdiplus-devel
Header files, libraries and development documentation for libgdiplus
This package contains the header files, static libraries and development
documentation for libgdiplus. If you like to develop programs using libgdiplus,
you will need to install libgdiplus-devel.



More information about the CentOS mailing list