[CentOS] Conexant fax/modem not faxing with sendfax

MHR mhullrich at gmail.com
Fri Nov 30 09:25:09 UTC 2007


I finally picked up a "real" modem (not a winmodem) and put it in my
machine.  I pulled down the hsfmodem driver from the source, got a license
and installed the driver at full power.

If I use wvdial, I can get out through the modem, so I know that works.

However, sendfax is rejecting the fax capability (from
/var/log/sendfax.log):

11/30 00:31:52  sendfax: interim release 1.1.33-Apr10
11/30 00:31:52   sendfax.c compiled at Jan  7 2007, 07:01:40
11/30 00:31:52  sending fax to 19496328403
11/30 00:31:52  checking WebOwnSig.ps
11/30 00:31:52   makelock(modem) called
11/30 00:31:52   do_makelock: lock='/var/lock/LCK..modem'
11/30 00:31:52   lock made
11/30 00:31:52   tss: set speed to 38400 (017)
11/30 00:31:52   tio_set_flow_control( HARD )
11/30 00:31:52 dem   fax_open_device succeeded, modem -> 4
11/30 00:31:52 dem   reading specific data for port 'modem'
11/30 00:31:52 dem   reading /etc/mgetty+sendfax/sendfax.config...
11/30 00:31:52 dem   conf lib: read: 'verbose y'
11/30 00:31:52 dem   conf lib: read: 'debug 5'
11/30 00:31:52 dem   conf lib: read: 'fax-devices modem'
11/30 00:31:52 dem   conf lib: read: 'fax-id 49 115 xxxxxxxx'
11/30 00:31:52 dem   conf lib: read: 'max-tries 3'
11/30 00:31:52 dem   conf lib: read: 'max-tries-continue y'
11/30 00:31:52 dem   key: 'fax-devices', type=1, flags=4, data=(ignored)
11/30 00:31:52 dem   key: 'modem-init', type=1, flags=0, data=(empty)
11/30 00:31:52 dem   key: 'modem-handshake', type=1, flags=0, data=(empty)
11/30 00:31:52 dem   key: 'modem-type', type=1, flags=1, data=auto
11/30 00:31:52 dem   key: 'modem-quirks', type=0, flags=0, data=(empty)
11/30 00:31:52 dem   key: 'fax-send-flow', type=4, flags=1, data=7
11/30 00:31:52 dem   key: 'fax-rec-flow', type=4, flags=1, data=7
11/30 00:31:52 dem   key: 'max-tries', type=0, flags=3, data=3
11/30 00:31:52 dem   key: 'max-tries-continue', type=3, flags=3, data=TRUE
11/30 00:31:52 dem   key: 'speed', type=0, flags=1, data=38400
11/30 00:31:52 dem   key: 'switchbd', type=0, flags=1, data=0
11/30 00:31:52 dem   key: 'open-delay', type=0, flags=0, data=(empty)
11/30 00:31:52 dem   key: 'ignore-carrier', type=3, flags=1, data=TRUE
11/30 00:31:52 dem   key: 'dial-prefix', type=1, flags=1, data=ATD
11/30 00:31:52 dem   key: 'fax-id', type=1, flags=3, data=49 115 xxxxxxxx
11/30 00:31:52 dem   key: 'poll-dir', type=1, flags=1, data=.
11/30 00:31:52 dem   key: 'normal-res', type=3, flags=1, data=FALSE
11/30 00:31:52 dem   key: 'fax-min-speed', type=0, flags=1, data=0
11/30 00:31:52 dem   key: 'fax-max-speed', type=0, flags=1, data=14400
11/30 00:31:52 dem   key: 'debug', type=0, flags=3, data=5
11/30 00:31:52 dem   key: 'verbose', type=3, flags=3, data=TRUE
11/30 00:31:52 dem   key: '', type=3, flags=1, data=FALSE
11/30 00:31:52 dem   key: 'page-header', type=1, flags=0, data=(empty)
11/30 00:31:52 dem   key: '', type=3, flags=1, data=FALSE
11/30 00:31:52 dem   key: '', type=3, flags=1, data=FALSE
11/30 00:31:52 dem   key: '', type=1, flags=1, data=
11/30 00:31:52 dem   tss: set speed to 38400 (017)
11/30 00:31:52 dem  mdm_send: 'ATV1Q0'
11/30 00:31:52 dem   mdm_command: string 'ATV1Q0'
11/30 00:31:52 dem   mdm_command: string 'OK' -> OK
11/30 00:31:52 dem  mdm_send: 'ATI'
11/30 00:31:52 dem   mdm_gis: string 1: '56000'
11/30 00:31:52 dem   mdm_identify: string '56000'
11/30 00:31:52 dem  Generic Rockwell modem (56000)
11/30 00:31:52 dem  mdm_send: 'ATI3'
11/30 00:31:52 dem   mdm_gis: string 1: 'hsfmodem-7.68.00.04x86_64full'
11/30 00:31:52 dem  mdm_send: 'ATI4'
11/30 00:31:52 dem   mdm_gis: string 1: 'Conexant HSF softmodem'
11/30 00:31:52 dem  additional info: 'Conexant HSF softmodem'
11/30 00:31:52 dem  modem quirks: 0004
11/30 00:31:52 dem  mdm_send: 'AT+FCLASS=2'
11/30 00:31:52 dem   mdm_command: string 'AT+FCLASS=2'
11/30 00:31:52 dem   mdm_command: string 'ERROR' -> ERROR
11/30 00:31:52 dem  mdm_send: 'AT+FCLASS=2.0'
11/30 00:31:52 dem   mdm_command: string 'AT+FCLASS=2.0'
11/30 00:31:52 dem   mdm_command: string 'ERROR' -> ERROR
11/30 00:31:52 dem  mdm_send: 'AT+FCLASS=2'
11/30 00:31:52 dem   mdm_command: string 'AT+FCLASS=2'
11/30 00:31:52 dem   mdm_command: string 'ERROR' -> ERROR
11/30 00:31:52 ##### failed: no class 2/2.0 fax modem, dev=modem

11/30 00:31:52 dem  fax_send: 'AT+FCLASS=0'
11/30 00:31:53 dem   removing lock file

Is there a newer version of sendfax I should get?  This was the latest one
available from yum on CentOS 5.0.

I also tried using 'fax' (in the efax package), and it also failed:

/usr/bin/efax: Fri Nov 30 01:19:25 2007 efax v 0.9 Copyright 1999 Ed Casas
efax: 19:25 compiled Jan  7 2007 02:20:44
efax: 19:25 TIFF version 4.2 file (little-endian)
efax: 19:25 TIFF directory at 8 with 20 tags, last image.
efax: 19:25 page 1 : WebOwnSig.ps.001 + 338 : 1728x2156 @ 204x196 dpi
TIFF/FAX
efax: 19:25 TIFF version 4.2 file (little-endian)
efax: 19:25 TIFF directory at 8 with 20 tags, last image.
efax: 19:25 page 2 : WebOwnSig.ps.002 + 338 : 1728x2156 @ 204x196 dpi
TIFF/FAX
efax: 19:25 TIFF version 4.2 file (little-endian)
efax: 19:25 TIFF directory at 8 with 20 tags, last image.
efax: 19:25 page 3 : WebOwnSig.ps.003 + 338 : 1728x2156 @ 204x196 dpi
TIFF/FAX
efax: 19:25 argv[0]=/usr/bin/efax
efax: 19:25 argv[1]=-v
efax: 19:25 argv[2]=ewin
efax: 19:25 argv[3]=-v
efax: 19:25 argv[4]=chewmainrxtf
efax: 19:25 argv[5]=-d/dev/modem
efax: 19:25 argv[6]=-x
efax: 19:25 argv[7]=/var/lock/LCK..modem
efax: 19:25 argv[8]=-iZ
efax: 19:25 argv[9]=-i&FE&D2S7=120
efax: 19:25 argv[10]=-i&C0
efax: 19:25 argv[11]=-iM1L0
efax: 19:25 argv[12]=-l
efax: 19:25 argv[13]=+0 000 000 0000
efax: 19:25 argv[14]=-kZ
efax: 19:25 argv[15]=-h
efax: 19:25 argv[16]=2007/11/30 01:19     +0 000 000 0000      from a Red
Hat Linux system     p. %d/%d
efax: 19:25 argv[17]=-t
efax: 19:25 argv[18]=T19496328403
efax: 19:25 argv[19]=WebOwnSig.ps.001
efax: 19:25 argv[20]=WebOwnSig.ps.002
efax: 19:25 argv[21]=WebOwnSig.ps.003
efax: 19:25 created text lock file /var/lock/LCK..modem
efax: 19:25 opened (null)
efax: 19:25 command  "Q0V1"
efax: 19:25 waiting 2.0 s
efax: 19:25 .592 [ATQ0V1<CR><CR><LF>]
efax: 19:25 .592 [OK<CR><LF>]
efax: 19:25 response "OK"
efax: 19:25 command  "Z"
efax: 19:25 waiting 5.0 s
efax: 19:25 .720 [ATZ<CR><CR><LF>]
efax: 19:25 .720 [OK<CR><LF>]
efax: 19:25 response "OK"
efax: 19:25 command  "&FE&D2S7=120"
efax: 19:25 waiting 5.0 s
efax: 19:25 .847 [AT&FE&D2S7=120<CR><CR><LF>]
efax: 19:25 .847 [OK<CR><LF>]
efax: 19:25 response "OK"
efax: 19:25 command  "&C0"
efax: 19:25 waiting 5.0 s
efax: 19:25 .970 [<CR><LF>OK<CR><LF>]
efax: 19:25 response "OK"
efax: 19:26 command  "M1L0"
efax: 19:26 waiting 5.0 s
efax: 19:26 .093 [<CR><LF>OK<CR><LF>]
efax: 19:26 response "OK"
efax: 19:26 command  "E0"
efax: 19:26 waiting 5.0 s
efax: 19:26 .216 [<CR><LF>OK<CR><LF>]
efax: 19:26 response "OK"
efax: 19:26 command  "I3"
efax: 19:26 waiting 5.0 s
efax: 19:26 .339 [<CR><LF>hsfmodem-7.68.00.04x86_64full<CR><LF>]
efax: 19:26 .339 [OK<CR><LF>]
efax: 19:26 response "OK"
efax: 19:26 command  "+FCLASS=?"
efax: 19:26 waiting 5.0 s
efax: 19:26 .462 [<CR><LF>0,1,1.0<CR><LF>]
efax: 19:26 .462 [<CR><LF>OK<CR><LF>]
efax: 19:26 response "OK"
efax: 19:26 command  "+FCLASS=1"
efax: 19:26 waiting 5.0 s
efax: 19:26 .563 [<CR><LF>OK<CR><LF>]
efax: 19:26 response "OK"
efax: 19:26 using 
(­ûin class efax: 19:26 Error: terminating on signal
-1789414544
efax: 19:26 failed -> 
efax: 19:26 failed -> 
efax: 19:26 failed -> 
efax: 19:26 command  "Q0V1"
efax: 19:26 waiting 2.0 s
efax: 19:26 .687 [<CR><LF>OK<CR><LF>]
efax: 19:26 response "OK"
efax: 19:26 command  "Z"
efax: 19:26 waiting 5.0 s
efax: 19:26 .793 [<CR><LF>OK<CR><LF>]
efax: 19:26 response "OK"
efax: 19:26 read HDB pid 15315 [     15315<LF>] from /var/lock/LCK..modem
(our pid)
efax: 19:26 removed lock file /var/lock/LCK..modem

The output from the fax program on the command line was:

fax send 19496328403 WebOwnSig.ps
WebOwnSig.ps.nnn is up-to-date
/usr/bin/efax: Fri Nov 30 01:19:25 2007 efax v 0.9 Copyright 1999 Ed Casas
efax: 19:25 opened /dev/modem
efax: 19:26 using hsfmodem-7.68.00.04x86_64full in class 1
efax: 19:26 Error: terminating on signal 11
efax: 19:26 failed -> WebOwnSig.ps.001
efax: 19:26 failed -> WebOwnSig.ps.002
efax: 19:26 failed -> WebOwnSig.ps.003
efax: 19:26 done, returning 5 (terminated by signal)
/usr/bin/fax: line 858: 15315 Segmentation fault      $NICE $EFAX -v "$VERB"
-v "$VERBLOG" -d/dev/$DEV $LOCK $INIT $SPKR $CLASSINIT $FCINIT $TXINIT
$TXCAP -l "$FROM" $RESET $HDRFONT -h "$HDR" $MANINIT -t "$TELNO" $FILES
>$logfile

Any advice?

Thanks.

mhr
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20071130/e3db8f9f/attachment.htm


More information about the CentOS mailing list