[CentOS] unstable libdg error when ./configure Perfparse on Nagios 2.x / CentOS 4.x

Garrick Staples garrick at usc.edu
Fri Nov 30 22:55:25 UTC 2007


On Fri, Nov 30, 2007 at 12:45:47PM -0800, Rogelio alleged:
> I'm trying to ./compile Perfparse on my Nagios CentOS 4.x box, but am
> having this error. (And am hoping someone here might point me in the
> right direction)

I just downloaded and tried it.  Turns our you need the gd-progs package
installed to get the gdlib-config script (necessary to satisfy perfparse's
configure).

After installing gd-progs, everything built fine.

So verify the following on your machine (make sure they are genuine centos
packages and not from a 3rd party repo):

$ rpm -q --qf '%{NAME}-%{VERSION}.%{RELEASE}.%{ARCH}\n' gd gd-devel gd-progs glib glib-devel
gd-2.0.28.5.4E.x86_64
gd-devel-2.0.28.5.4E.x86_64
gd-progs-2.0.28.5.4E.x86_64
glib-1.2.10.15.x86_64
glib-1.2.10.15.i386
glib-devel-1.2.10.15.x86_64

Then start over with a clean build and try configure and make again.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20071130/290258c9/attachment.bin


More information about the CentOS mailing list