[CentOS] GFS-kernel module - Version Magic Error

Manish Kathuria mkathuria at tuxtechnologies.co.in
Sat Oct 6 15:23:24 UTC 2007


Are the RPMs  for the latest GFS kernel module
GFS-kernel-2.6.9-72.2.0.8 to be used with the version 2.6.9-55.0.9.EL
available ? I tried to compile the Source RPMs available from the Red
Hat site but the modules can't be loaded because of invalid module
format arising from version magic issues. The syslog shows:

 node0 kernel: gfs: version magic '2.6.9-55.0.9.ELsmp SMP 686 REGPARM
4KSTACKS gcc-3.2' should be '2.6.9-55.0.9.ELsmp SMP 686 REGPARM
4KSTACKS gcc-3.4'

node0 modprobe: FATAL: Error inserting gfs
(/lib/modules/2.6.9-55.0.9.ELsmp/kernel/fs/gfs/gfs.ko): Invalid module
format

The error message is actually surprising since the Source RPM has been
compiled on a system having gcc-3.4. To complicate matters the modinfo
indicates

vermagic:       2.6.9-55.0.9.ELsmp SMP 686 REGPARM 4KSTACKS gcc-3.2

When are the CentOS builds expected for this module ?

Thanks,

Manish



More information about the CentOS mailing list