[CentOS] Upgrading Java on CentOS 4.5

Antonio da Silva Martins Junior asmartins at uem.br
Thu Oct 18 18:40:21 UTC 2007


----- "Scott Moseman" <scmoseman at gmail.com> escreveu:
> # rpm -qa | grep -E '^(java|jdk|jre)-'
> jre-1.6.0_03-fcs
> java-1.4.2-gcj-compat-1.4.2.0-27jpp
> jdk-1.6.0_03-fcs
>=20
> java is a CentOS package.  jdk and jre are from Sun.
> (I need Java >=3D 1.5.0 for an application I'm installing.)
>=20
> # update-alternatives --config java
>=20
> There are 1 programs which provide 'java'.
>=20
>   Selection    Command
> -----------------------------------------------
> *+ 1           /usr/lib/jvm/jre-1.4.2-gcj/bin/java
>=20
> But how do I tell my system to use the 1.6.0 version?
> Is there a step that I'm missing to finish the upgrading?

Hi Scott,

  Take a look on http://www.jpackage.org

  On that repo are RPMs to change the alternatives, and docs on howto
install it.

     Antonio.

--=20
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Antonio S. Martins Jr. - Support Analist | "Only The Shadow Knows     |
| Universidade Estadual de Maring=C3=A1 - Brasil|   what evil lurks in the =
  |
| NPD - N=C3=BAcleo de Processamento de Dados   |       Heart of Men!"     =
  |
| E-Mail: asmartins at uem.br / shadow at uem.br | !!! Linux User: 52392 !!!  |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+


--=20
Esta mensagem foi verificada pelo sistema de antiv=EDrus e
 acredita-se estar livre de perigo.




More information about the CentOS mailing list