[CentOS] Changing php5 with php4 in CentOS 5

Johnny Hughes johnny at centos.org
Fri Oct 19 09:51:31 UTC 2007


Can Cizer wrote:
> This can be a solution,nevertheless the codes were not written by
> myself. Some of them were taken as already written.
> I found some php4 rpms for Centos 5. If i change php-mysql-4 rpm with
> php-mysql-5 , can there be any problem? 

Sure, there could be many problems ... all the other things that are
included (mysql, apache, etc.) expect php-5 and not php-4.

If you have a long term requirement for php-4, you should use CnetOS-4.x
(currently 4.5 ... which will be supported until 2012) instead of
CentOS-5 as it contains php-4.

> 
>  
> On 10/18/07, *Kai Schaetzl* <maillists at conactive.com
> <mailto:maillists at conactive.com>> wrote:
> 
>     John Allen wrote on Thu, 18 Oct 2007 15:02:48 +0100:
> 
>     > Fix you pages to work with PHP5 as well as PHP4, it should be
>     pretty easy.
> 
>     Indeed. Watch the error messages and then fix one by one. Most likely
>     there's a MySQL driver problem.
> 


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
Url : http://lists.centos.org/pipermail/centos/attachments/20071019/c2896ff1/signature.bin


More information about the CentOS mailing list