[CentOS] Display resolution problem on Centos 4.5

fred smith fredex at fcshome.stoneham.ma.us
Fri Oct 19 23:52:39 UTC 2007


I've got a Centos 4.5 box at work (installed at 4.0 and kept up to date)
that's having a really weird problem I haven't been able to figure out.

It's been doing on for a loong time but today it just got my goat and I
spent some bit of time fighting with it, unsuccessfully.

/etc/X11/xorg.conf specifies that the display resolution should be 1280x1024.
When root logs in it is. when a user named 'interface' logs in it is.
When I log in with my normal login, 'fredex', it isn't. I get 1152x864.
when I look at the "screen resolution" utility on the preferences menu it
says 1280x1024. when I look at the "display" utility on the "system settings"
menu it says 1280x1024.

but using the monitor's OSD settings, the monitor says it's 1152x864.

I CAN force it to 1280x1024 by using 'xrandr', and it then works fine
at that resolution until I log in the next time.

I'm left to conclude that at some point in the murky past that I must
have done SOMETHING in Gnome that causes Gnome to somehow mess with the
resolution when I login but not when other users do. But I've been reading
the Centos forums, the Red Hat Knowledgebase, and the FAQs at gnome.org,
and none of them  has shed any light on this issue.

Can any of you help please?

Thanks in advance!

-- 
---- Fred Smith -- fredex at fcshome.stoneham.ma.us -----------------------------
                       I can do all things through Christ 
                              who strengthens me.
------------------------------ Philippians 4:13 -------------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20071019/6e587bbc/attachment.bin


More information about the CentOS mailing list