[CentOS] rebuilding rpmdevtools from epel5 SRC has fc7 dependent

mark pryor tlviewer at yahoo.com
Wed Sep 19 02:00:02 UTC 2007


hello,

I'm suprised that an SRC.RPM from the rhel5 repo needs a file from FC7.

I grabbed rpmdevtools from
http://download.fedora.redhat.com/pub/epel/5/

it rebuilds fine as EL5, but when I go to install it, it requires a version of rpm-build higher than the C5 base version (4.4.2-37)
--------------------- grab dependencies -------------
$ rpm -qpR rpmdevtools-6.1-0.1.noarch.rpm
...
config(rpmdevtools) = 6.1-0.1
cpio
diffutils
fakeroot
...
perl(File::Spec)
perl(File::Temp)
perl(FileHandle)
perl(Getopt::Long)
perl(strict)
redhat-rpm-config
rpm-build >= 4.4.2.1
rpm-python
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
...
--------------------- end snip ---------------
I reverted to the lower version 5.3.xxx and it works fine.
--
Mark

       
---------------------------------
Yahoo! oneSearch: Finally,  mobile search that gives answers, not web links. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20070918/69fc4cc7/attachment.htm


More information about the CentOS mailing list