[CentOS] Probelm updatring a fresh install

James B. Byrne byrnejb at harte-lyne.ca
Sat Sep 29 13:43:28 UTC 2007


I just installed CentOS-5 but when I try to update I get this:

# yum clean all
Loading "installonlyn" plugin
Cleaning up Everything
[root at inet02 ~]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
base                      100% |=========================| 1.1 kB    00:00
updates                   100% |=========================|  951 B    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 798 kB    00:16
base      : ################################################## 2334/2334
Added 2334 new packages, deleted 0 old in 21.02 seconds
primary.xml.gz            100% |=========================| 310 kB    00:06
updates   : ################################################## 706/706
Added 706 new packages, deleted 0 old in 6.36 seconds
primary.xml.gz            100% |=========================|  157 B    00:00
Added 0 new packages, deleted 0 old in 0.00 seconds
primary.xml.gz            100% |=========================|  66 kB    00:01
extras    : ################################################## 249/249
Added 249 new packages, deleted 0 old in 1.47 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for pidgin to pack into transaction set.
pidgin-2.0.2-3.el5.i386.r 100% |=========================|  84 kB    00:01
---> Package pidgin.i386 0:2.0.2-3.el5 set to be updated
---> Downloading header for libpurple to pack into transaction set.
libpurple-2.0.2-3.el5.i38 100% |=========================|  53 kB    00:00
---> Package libpurple.i386 0:2.0.2-3.el5 set to be updated
---> Downloading header for kmod-gnbd to pack into transaction set.
kmod-gnbd-0.1.3-4.2.6.18_ 100% |=========================| 4.3 kB    00:00
---> Package kmod-gnbd.i686 0:0.1.3-4.2.6.18_8.1.10.el5 set to be installed
---> Downloading header for kmod-gfs to pack into transaction set.
kmod-gfs-0.1.16-5.2.6.18_ 100% |=========================| 5.2 kB    00:00
---> Package kmod-gfs.i686 0:0.1.16-5.2.6.18_8.1.10.el5 set to be installed
--> Running transaction check
--> Processing Dependency: kernel-i686 = 2.6.18-8.1.10.el5 for package:
kmod-gfs
--> Processing Dependency: libhowl.so.0 for package: libpurple
--> Processing Dependency: kernel-i686 = 2.6.18-8.1.10.el5 for package:
kmod-gnbd
--> Processing Dependency: libmeanwhile.so.1 for package: libpurple
--> Processing Dependency: libgaim.so.0 for package: nautilus-sendto
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kernel to pack into transaction set.
kernel-2.6.18-8.1.10.el5. 100% |=========================| 204 kB    00:04
---> Package kernel.i686 0:2.6.18-8.1.10.el5 set to be installed
---> Downloading header for meanwhile to pack into transaction set.
meanwhile-1.0.2-5.el5.i38 100% |=========================| 4.7 kB    00:00
---> Package meanwhile.i386 0:1.0.2-5.el5 set to be updated
---> Downloading header for avahi-compat-howl to pack into transaction set.
avahi-compat-howl-0.6.16- 100% |=========================| 8.8 kB    00:00
---> Package avahi-compat-howl.i386 0:0.6.16-1.el5 set to be updated
--> Running transaction check
--> Processing Dependency: libgaim.so.0 for package: nautilus-sendto
--> Finished Dependency Resolution
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.18-8.el5 set to be erased
--> Running transaction check
--> Processing Dependency: kernel-i686 = 2.6.18-8.el5 for package: kmod-gfs
--> Processing Dependency: libgaim.so.0 for package: nautilus-sendto
--> Processing Dependency: kernel-i686 = 2.6.18-8.el5 for package: kmod-gnbd
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package kmod-gfs.i686 0:0.1.16-5.2.6.18_8.el5 set to be erased
---> Package kmod-gnbd.i686 0:0.1.3-4.2.6.18_8.el5 set to be erased
--> Running transaction check
--> Processing Dependency: libgaim.so.0 for package: nautilus-sendto
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 kmod-gfs                i686       0.1.16-5.2.6.18_8.1.10.el5  updates   
       133 k
 kmod-gnbd               i686       0.1.3-4.2.6.18_8.1.10.el5  updates    
       13 k
 libpurple               i386       2.0.2-3.el5      updates           6.0 M
     replacing  gaim.i386 2:2.0.0-0.28.beta5.el5

 pidgin                  i386       2.0.2-3.el5      updates           6.0 M
     replacing  gaim.i386 2:2.0.0-0.28.beta5.el5

Removing:
 kernel                  i686       2.6.18-8.el5     installed          34 M
Installing for dependencies:
 avahi-compat-howl       i386       0.6.16-1.el5     base               28 k
 kernel                  i686       2.6.18-8.1.10.el5  updates           
12 M
 meanwhile               i386       1.0.2-5.el5      updates           108 k
Removing for dependencies:
 kmod-gfs                i686       0.1.16-5.2.6.18_8.el5  installed      
  300 k
 kmod-gnbd               i686       0.1.3-4.2.6.18_8.el5  installed       
  25 k

Transaction Summary
=============================================================================
Install      7 Package(s)
Update       0 Package(s)
Remove       3 Package(s)

Total download size: 25 M
Is this ok [y/N]: y
Downloading Packages:
(1/7): kmod-gfs-0.1.16-5. 100% |=========================| 133 kB    00:02
(2/7): libpurple-2.0.2-3. 100% |=========================| 6.0 MB    02:12
(3/7): kernel-2.6.18-8.1. 100% |=========================|  12 MB    03:56
(4/7): pidgin-2.0.2-3.el5 100% |=========================| 6.0 MB    01:53
(5/7): meanwhile-1.0.2-5. 100% |=========================| 108 kB    00:02
(6/7): avahi-compat-howl- 100% |=========================|  28 kB    00:00
(7/7): kmod-gnbd-0.1.3-4. 100% |=========================|  13 kB    00:00
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  package kernel-2.6.18-8.1.14.el5 (which is newer than
kernel-2.6.18-8.1.10.el5) is already installed

Error Summary
-------------


The problem is with kmod-gfs and kmod-gnbd.  I have tried cleaning yum so
I am thinking the difficulty lies in the packaging.  How do I resolve this
short of removing the offending packages?

Regards,

-- 
***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3




More information about the CentOS mailing list