[CentOS] perl

Bowie Bailey Bowie_Bailey at BUC.com
Thu Aug 21 15:54:33 UTC 2008


Mad Unix wrote:
> Am trying to install ftpsync-1.2.33, prerequisite
> [root at PowerEdge1 ftpsync-1.2.33]# cat README | grep ::
> - File::Find, IO::Handle
> - Net::FTP
> - File::Listing
> 
> cpan[2]> install File::Find
> Running install for module 'File::Find'
> The most recent version "1.12" of the module "File::Find"
> is part of the perl-5.10.0 distribution. To install that, you need to
>   run force install File::Find   --or--
>   install R/RG/RGARCIA/perl-5.10.0.tar.gz

Cpan is trying to install the latest File::Find, but since File::Find is
part of the base Perl distribution, it can't upgrade it without
upgrading your Perl version as well (which is not allowed by default).

To determine if you have File::Find already installed (which you
should), do this:

perl -e 'use File::Find'

If that runs without errors, it is already installed and you don't have
to worry about it.

-- 
Bowie


More information about the CentOS mailing list