[CentOS] Re: Re: Problems with perl upgrading CentOS 5.1 to 5.2 [SOLVED?]

ArcosCom Linux User linux at arcoscom.com
Tue Aug 26 07:06:21 UTC 2008


Taking a view into perl packages (classes) needed by spamassassin
(qmail-toaster package), I saw that there are a script that install the
classes using CPAN.

I discovered that CPAN installed packages goes into a diferent directory
that distro ones.

The workaround (solution) I found is rename this directory and install the
needed packages manually from rpmforge repository.

All appears to be working now.

The steps have been:
   1) Rename /usr/lib/perl5/site_perl.
   2) Update perl packages.
   3) Install the needed clases as packages (from rpmforge) instead from
CPAN.
   4) Reinstall packages broken because they install manually any
propietary perl classes into the system (vmware-server for example).

Thanks to all for the help.

Regards

El Lun, 25 de Agosto de 2008, 6:00, Eric Shubert escribió:
> Eric Shubert wrote:
>> Here's a list of perl modules on an up-to-date COS5.2 toaster. I would
>> try
>> upgrading any packages that do not match these.
>>
>> You do have the proper rpmforge yum repo configured, don't you? It
>> appears
>> that you have some "el5.rf" packages, but there are some packages for
>> which
>> there are updates available.
>>
>> I'm not confident that this will fix your problem, but it won't hurt,
>> and
>> might just fix it. There's something on your system hanging around from
>> a
>> 2.6.9 kernel, which I think is earlier than FC5 and COS5. Strange. Might
>> have picked it up with the latest upgrade? I can't imagine how, unless
>> you
>> had an incorrect repo configured at some point.
>
> (Oops - forgot the list!):
> [root at doris ~]# yum list installed | grep perl
> perl.i386                                4:5.8.8-10.el5_2.3     installed
> perl-Archive-Tar.noarch                  1.38-1.el5.rf          installed
> perl-Compress-Raw-Zlib.i386              2.011-1.el5.rf         installed
> perl-Compress-Zlib.noarch                2.011-1.el5.rf         installed
> perl-Crypt-OpenSSL-Bignum.i386           0.04-1.el5.rf          installed
> perl-Crypt-OpenSSL-RSA.i386              0.25-1.el5.rf          installed
> perl-Crypt-PasswdMD5.noarch              1.3-1.2.el5.rf         installed
> perl-DBD-MySQL.i386                      3.0007-1.fc6           installed
> perl-DBI.i386                            1.605-1.el5.rf         installed
> perl-Digest-HMAC.noarch                  1.01-15                installed
> perl-Digest-SHA.i386                     5.47-1.el5.rf          installed
> perl-Digest-SHA1.i386                    2.11-1.2.1             installed
> perl-Encode-Detect.i386                  1.01-1.el5.rf          installed
> perl-Error.noarch                        0.17014-1.el5.rf       installed
> perl-Geography-Countries.noarch          1.4-2.2.el5.rf         installed
> perl-HTML-Parser.i386                    3.56-1.el5.rf          installed
> perl-HTML-Tagset.noarch                  3.20-1.el5.rf          installed
> perl-IO-Compress-Base.noarch             2.011-1.el5.rf         installed
> perl-IO-Compress-Zlib.noarch             2.011-1.el5.rf         installed
> perl-IO-Socket-INET6.noarch              2.54-1.el5.rf          installed
> perl-IO-Socket-SSL.noarch                1.13-1.el5.rf          installed
> perl-IO-Zlib.noarch                      1.09-1.el5.rf          installed
> perl-IP-Country.noarch                   2.24-1.el5.rf          installed
> perl-Mail-DKIM.noarch                    0.32-1.el5.rf          installed
> perl-Mail-DomainKeys.noarch              1.0-1.el5.rf           installed
> perl-Mail-SPF.noarch                     2.005-1.el5.rf         installed
> perl-Mail-SPF-Query.noarch               1.999.1-2.el5.rf       installed
> perl-MailTools.noarch                    2.03-1.el5.rf          installed
> perl-Net-CIDR.noarch                     0.11-1.2.el5.rf        installed
> perl-Net-CIDR-Lite.noarch                0.20-1.2.el5.rf        installed
> perl-Net-DNS.i386                        0.63-1.el5.rf          installed
> perl-Net-Daemon.noarch                   0.43-1.el5.rf          installed
> perl-Net-IP.noarch                       1.25-2.fc6             installed
> perl-Net-Ident.noarch                    1.20-1.2.el5.rf        installed
> perl-Net-SSLeay.i386                     1.32-1.el5.rf          installed
> perl-NetAddr-IP.i386                     4.007-1.el5.rf         installed
> perl-PlRPC.noarch                        0.2020-1.el5.rf        installed
> perl-Socket6.i386                        0.20-1.el5.rf          installed
> perl-String-CRC32.i386                   1.4-2.fc6              installed
> perl-Sys-Hostname-Long.noarch            1.4-1.2.el5.rf         installed
> perl-TimeDate.noarch                     1:1.16-5.el5           installed
> perl-URI.noarch                          1.35-3                 installed
> perl-libwww-perl.noarch                  5.805-1.1.1            installed
> perl-version.i386                        0.74-1.el5.rf          installed
>
>
>> ArcosCom Linux User wrote:
>>> Linux myhost 2.6.18-92.1.10.1.el5_ArcosComPAE #1 SMP Wed Aug 6 22:16:52
>>> CEST 2008 i686 i686 i386 GNU/Linux
>>>
>>> El Lun, 25 de Agosto de 2008, 0:37, Eric Shubert escribió:
>>>> What does
>>>> $ uname -a
>>>> show you?
>>>>
>>>> ArcosCom Linux User wrote:
>>>>> As I said in the e-mail, I reinstalled all CentOS 5.2 perl* packages
>>>>> that
>>>>> I had installed.
>>>>>
>>>>> I have no idea about perl and how to fight versus it. I only know:
>>>>>    1) This system where a FC5 some years ago with no problem.
>>>>>    2) I upgraded to CentOS 5 (a year ago) with no problem.
>>>>>    3) I upgraded to CentOS 5.1 (some months ago) with no problem.
>>>>>    4) I upgraded to CentOS 5.2 (some days ago) and I encounter this
>>>>> problem.
>>>>>
>>>>> I think that in this process no exists any CentOS 4 packages
>>>>> installed.
>>>>> I
>>>>> use "rpmforge" repository too (don't think this were the problem
>>>>> yet).
>>>>>
>>>>> I remember I use CPAN to install (some months ago) 2 or three
>>>>> packages
>>>>> that weren't in repos. Perhaps, some help, could be how to "reinit"
>>>>> the
>>>>> perl configuration to original values (includes, for example). I
>>>>> don't
>>>>> know how to use CPAN really.
>>>>>
>>>>> These are the list of "*perl*" packages I have installed:
>>>>>
>>>>> # yum list installed | grep perl
>>>>> mod_perl.i386                            2.0.2-6.3.el5
>>>>> installed
>>>>> newt-perl.i386                           1.08-9.2.2
>>>>> installed
>>>>> openssl-perl.i386                        0.9.8b-10.el5
>>>>> installed
>>>>> perl.i386                                4:5.8.8-10.el5_2.3
>>>>> installed
>>>>> perl-Archive-Tar.noarch                  1.30-1.fc6
>>>>> installed
>>>>> perl-Archive-Zip.noarch                  1.16-1.2.1
>>>>> installed
>>>>> perl-Authen-Radius.noarch                0.13-1.el5.centos
>>>>> installed
>>>>> perl-BSD-Resource.i386                   1.28-1.fc6.1
>>>>> installed
>>>>> perl-Bit-Vector.i386                     6.4-2.2.2.1
>>>>> installed
>>>>> perl-Carp-Clan.noarch                    5.3-1.2.1
>>>>> installed
>>>>> perl-Compress-Raw-Zlib.i386              2.011-1.el5.rf
>>>>> installed
>>>>> perl-Compress-Zlib.i386                  1.42-1.fc6
>>>>> installed
>>>>> perl-Convert-ASN1.noarch                 0.20-1.1
>>>>> installed
>>>>> perl-Crypt-Blowfish.i386                 2.10-1.2.el5.rf
>>>>> installed
>>>>> perl-Crypt-CBC.noarch                    2.24-1.el5.rf
>>>>> installed
>>>>> perl-Crypt-DES.i386                      2.05-3.2.el5.rf
>>>>> installed
>>>>> perl-Crypt-OpenSSL-Bignum.i386           0.04-1.el5.rf
>>>>> installed
>>>>> perl-Crypt-PasswdMD5.noarch              1.3-1.2.el5.rf
>>>>> installed
>>>>> perl-Crypt-SSLeay.i386                   0.51-11.el5
>>>>> installed
>>>>> perl-DBD-MySQL.i386                      3.0007-1.fc6
>>>>> installed
>>>>> perl-DBD-Pg.i386                         1.49-1.fc6
>>>>> installed
>>>>> perl-DBI.i386                            1.52-1.fc6
>>>>> installed
>>>>> perl-Data-HexDump.noarch                 0.02-1.el5.centos
>>>>> installed
>>>>> perl-Date-Calc.i386                      5.4-1.2.2.1
>>>>> installed
>>>>> perl-DateManip.noarch                    5.44-1.2.1
>>>>> installed
>>>>> perl-Digest-HMAC.noarch                  1.01-15
>>>>> installed
>>>>> perl-Digest-SHA1.i386                    2.11-1.2.1
>>>>> installed
>>>>> perl-HTML-Parser.i386                    3.55-1.fc6
>>>>> installed
>>>>> perl-HTML-Tagset.noarch                  3.10-2.1.1
>>>>> installed
>>>>> perl-IO-Compress-Base.noarch             2.011-1.el5.rf
>>>>> installed
>>>>> perl-IO-Compress-Zlib.noarch             2.011-1.el5.rf
>>>>> installed
>>>>> perl-IO-Socket-INET6.noarch              2.51-2.fc6
>>>>> installed
>>>>> perl-IO-Socket-SSL.noarch                1.01-1.fc6
>>>>> installed
>>>>> perl-IO-String.noarch                    1.08-1.1.1
>>>>> installed
>>>>> perl-IO-Zlib.noarch                      1.04-4.2.1
>>>>> installed
>>>>> perl-LDAP.noarch                         1:0.33-3.fc6
>>>>> installed
>>>>> perl-Mail-POP3Client.noarch              2.17-1.el5.centos
>>>>> installed
>>>>> perl-MailTools.noarch                    1.77-1.el5.centos
>>>>> installed
>>>>> perl-Mozilla-LDAP.i386                   1.5.2-4.el5
>>>>> installed
>>>>> perl-NKF.i386                            2.07-1.1.fc6
>>>>> installed
>>>>> perl-Net-DNS.i386                        0.59-3.el5
>>>>> installed
>>>>> perl-Net-Daemon.noarch                   0.43-1.el5.rf
>>>>> installed
>>>>> perl-Net-IMAP-Simple.noarch              1.17-1.el5.centos
>>>>> installed
>>>>> perl-Net-IMAP-Simple-SSL.noarch          1.3-1.el5.centos
>>>>> installed
>>>>> perl-Net-IP.noarch                       1.25-2.fc6
>>>>> installed
>>>>> perl-Net-SSLeay.i386                     1.30-4.fc6
>>>>> installed
>>>>> perl-Net-Telnet.noarch                   3.03-5
>>>>> installed
>>>>> perl-PlRPC.noarch                        0.2020-1.el5.rf
>>>>> installed
>>>>> perl-SGMLSpm.noarch                      1.03ii-16.2.1
>>>>> installed
>>>>> perl-Socket6.i386                        0.19-3.fc6
>>>>> installed
>>>>> perl-String-CRC32.i386                   1.4-2.fc6
>>>>> installed
>>>>> perl-TimeDate.noarch                     1:1.16-5.el5
>>>>> installed
>>>>> perl-URI.noarch                          1.35-3
>>>>> installed
>>>>> perl-XML-LibXML.i386                     1.58-5
>>>>> installed
>>>>> perl-XML-LibXML-Common.i386              0.13-8.2.2
>>>>> installed
>>>>> perl-XML-NamespaceSupport.noarch         1.09-1.2.1
>>>>> installed
>>>>> perl-XML-Parser.i386                     2.34-6.1.2.2.1
>>>>> installed
>>>>> perl-XML-SAX.noarch                      0.14-5
>>>>> installed
>>>>> perl-libwww-perl.noarch                  5.805-1.1.1
>>>>> installed
>>>>> perl-libxml-perl.noarch                  0.08-1.2.1
>>>>> installed
>>>>> perl-rrdtool.i386                        1.2.23-1.el5.rf
>>>>> installed
>>>>> perl-suidperl.i386                       4:5.8.8-10.el5_2.3
>>>>> installed
>>>>> perl-version.i386                        0.74-1.el5.rf
>>>>> installed
>>>>>
>>>>> Anyone could help me? Thanks!!
>>>>>
>>>>> El Dom, 24 de Agosto de 2008, 15:33, Matt Hyclak escribió:
>>>>>> On Sun, Aug 24, 2008 at 12:29:29PM +0200, ArcosCom Linux User
>>>>>> enlightened
>>>>>> us:
>>>>>>> I'm having problems with perl.
>>>>>>> I'm receivings this e-mails from logwatch everyday and appears to
>>>>>>> be a
>>>>>>> problem with perl.
>>>>>>>
>>>>>>> I explain a bit before expose the errors that I received: I tried
>>>>>>> to
>>>>>>> download all perl* packages, uninstall the repeated ones and
>>>>>>> reinstall
>>>>>>> all
>>>>>>> packages where installed.
>>>>>>>
>>>>>>> I need some help to try to solve this problem, because is a
>>>>>>> production
>>>>>>> server and I can't uninstall many working packages that depends on
>>>>>>> perl*
>>>>>>> ones.
>>>>>>>
>>>>>>> I read about similar problem in CentOS forums, with no sucess.
>>>>>>>
>>>>>>> Many thanks to all!!!
>>>>>>>
>>>>>>> Here is the report from logwatch:
>>>>>>>
>>>>>>> /etc/cron.daily/0logwatch:
>>>>>>>
>>>>>>> Errno architecture (i386-linux-thread-multi-2.6.9-42.0.3.elsmp)
>>>>>>> does
>>>>>>> not
>>>>>>> match executable architecture
>>>>>>> (i386-linux-thread-multi-2.6.18-53.1.14.el5pae) at
>>>>>> It would appear you've installed el4 perl packages on an el5 system,
>>>>>> or
>>>>>> vice
>>>>>> versa.
>>>>>>
>>>>>> Matt
>>>>>>
>>>>>> --
>>>>>> Matt Hyclak
>>>>>> Systems and Operations
>>>>>> Office of Information Technology
>>>>>> Ohio University
>>>>>> (740) 593-1222
>>>>>> _______________________________________________
>>>>>> CentOS mailing list
>>>>>> CentOS at centos.org
>>>>>> http://lists.centos.org/mailman/listinfo/centos
>>>>>>
>>
>>
>
>
> --
> -Eric 'shubes'
>
> ---------------------------------------------------------------------
>      QmailToaster hosted by: VR Hosted <http://www.vr.org>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: qmailtoaster-list-unsubscribe at qmailtoaster.com
> For additional commands, e-mail: qmailtoaster-list-help at qmailtoaster.com
>
>




More information about the CentOS mailing list