[CentOS] C 5.2 and VMWAre error

MHR mhullrich at gmail.com
Fri Aug 29 20:39:05 UTC 2008


On Fri, Aug 29, 2008 at 12:13 PM, Scott Ehrlich <scott at mit.edu> wrote:
> A colleague has a newly built 64-bit CentOS 5.0 system that, through yum
> updates, has become CentOS 5.2.    VMWare Workstation and Player work fine
> for my account on it.   But a recent configuration of something under their
> account has produced:
>
> vmplayer
> GTK Accessibility Module initialized
> /usr/lib/vmware/bin/vmplayer: symbol lookup error: /usr/lib64/libspi.so.0:
> undefined symbol: atk_hyperlink_impl_get_type
>
> The same error (I think) comes up if I try to invoke vmware (Workstation).
>
> As a reminder, if I su - <my account> and run vmplayer, it works.
>
> I typed env > env.txt for both accounts, diff'd them, and didn't see
> anything obvious to my eyes.
>
> I did the same for set > set.txt.  Again,  nothing obvious.   I rebooted the
> system.  Same problem.
>
> What is the most likely cause under their account if, on the same system, it
> works fine for me?
>

It looks like a permissions problem if it works for root (always) and
not for a non-root user.

If it's not too much trouble, I would uninstall and reinstall both,
and make sure your root permissions are set properly (002, IIRC).

HTH

mhr


More information about the CentOS mailing list