[CentOS] vim helpfile tag issues

Spiro Harvey spiro at knossos.net.nz
Wed Dec 17 04:04:24 UTC 2008


> > Is it me, or do you have a newer vim than CentOS is shipping ?
> >     [root at rhun ~]# rpm -q vim-common
> >     vim-common-7.0.109-4.el5_2.4z
> > Is it possible you messed something up yourself ?
> 
> And before everyone gets on top of me for being rude. I can confirm
> this happens on 7.0.109 as well. Apparently it cannot handle zip
> files ?
> 


well, that is interesting. I have my own repos for our in-house
software, but none of that is vim. all my vim installs are from
standard centos packages..


# rpm -qa | grep vim
vim-minimal-7.0.109-4.el5_2.4z
vim-common-7.0.109-4.el5_2.4z
vim-enhanced-7.0.109-4.el5_2.4z

# vim --version
VIM - Vi IMproved 7.0 (2006 May 7, compiled Nov 25 2008 11:43:45)
Included patches: 1, 3-4, 7-9, 11, 13-17, 19-26, 29-31, 34-44, 47,
50-56, 58-64, 66-73, 75, 77-92, 94-107, 109, 202, 234-235, 237 
Modified by <bugzilla at redhat.com> 
Compiled by <bugzilla at redhat.com>
[snipped extra stuff]


and if I enter the binary just by typing "vim" or "vi" the splash
screen tells me: version 7.0.237

the vim and vi binaries are both from different packages and are quite
different:

[root at web1 doc]# ls -lad $(which vi)
-rwxr-xr-x 1 root root 593160 Nov 26 05:44 /bin/vi
[root at web1 doc]# ls -lad $(which vim)
-rwxr-xr-x 1 root root 2723516 Nov 26 05:44 /usr/bin/vim

vim comes from vim-enhanced, and vi comes from vim-minimal.


ah, I wasn't as thorough as I thought. :)

"vi" exhibits the faulty behaviour, while "vim" works correctly with
the compressed help files..




-- 
Spiro Harvey                  Knossos Networks Ltd
021-295-1923                    www.knossos.net.nz
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20081217/99e0c696/attachment.bin 


More information about the CentOS mailing list