[CentOS] no sound after hibernation

partha chowdhury kira.laucas at gmail.com
Mon Dec 22 09:11:46 UTC 2008


I am not getting any sound after hibernating

> [freedom at station2 ~]$ uname -a
> Linux station2.domain2.example.com 2.6.18-92.1.22.el5 #1 SMP Tue Dec 16 12:03:43 EST 2008 i686 athlon i386 GNU/Linux
> 
> [freedom at station2 ~]$ /sbin/lspci -v|grep -i audio
> 00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
> 01:06.0 Multimedia audio controller: Creative Labs [SB Live! Value] EMU10k1X
> 
> 
> [freedom at station2 ~]$ rpm -qa|grep -i alsa
> alsa-lib-devel-1.0.14-1.rc4.el5
> alsa-kmdl-2.6.18-92.1.13.el5-1.0.17-70.el5
> alsa-lib-1.0.14-1.rc4.el5
> alsa-utils-1.0.14-3.rc4.el5

> [root at station2 freedom]# /sbin/lsmod |grep -i snd
> snd_hda_intel          24793  2 
> snd_hda_codec         210881  1 snd_hda_intel
> snd_emu10k1x           21957  1 
> snd_rawmidi            26561  1 snd_emu10k1x
> snd_ac97_codec         93025  1 snd_emu10k1x
> snd_seq_dummy           7877  0 
> snd_seq_oss            32577  0 
> snd_seq_midi_event     11073  1 snd_seq_oss
> snd_seq                49585  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
> snd_seq_device         11725  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
> snd_pcm_oss            42945  0 
> snd_mixer_oss          19009  3 snd_pcm_oss
> snd_pcm                72005  5 snd_hda_intel,snd_hda_codec,snd_emu10k1x,snd_ac97_codec,snd_pcm_oss
> snd_timer              24517  2 snd_seq,snd_pcm
> snd                    52421  14 snd_hda_intel,snd_hda_codec,snd_emu10k1x,snd_rawmidi,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
> ac97_bus                6337  1 snd_ac97_codec
> soundcore              11553  3 snd
> snd_page_alloc         14281  3 snd_hda_intel,snd_emu10k1x,snd_pcm

here are the logs after going to and waking from hibernation :

from /var/log/messages:

> Dec 22 14:20:10 station2 gnome-power-manager: (freedom) Hibernating computer because the DBUS method Hibernate() was invoked
> Dec 22 14:20:13 station2 ntpd[5274]: ntpd exiting on signal 15
> Dec 22 14:20:15 station2 kernel: Disabling non-boot CPUs ...
> Dec 22 14:20:15 station2 kernel: Breaking affinity for irq 50
> Dec 22 14:20:15 station2 kernel: Breaking affinity for irq 82
> Dec 22 14:20:15 station2 kernel: Breaking affinity for irq 106
> Dec 22 14:20:15 station2 kernel: CPU 1 is now offline
> Dec 22 14:20:15 station2 kernel: SMP alternatives: switching to UP code
> Dec 22 14:22:18 station2 kernel: CPU1 is down
> Dec 22 14:22:18 station2 kernel: Stopping tasks: ==============================================================================================================================================|
> Dec 22 14:22:18 station2 kernel: Shrinking memory...  ^H-^H\^H|^H/^H-^H\^H|^H/^Hdone (110403 pages freed)
> Dec 22 14:22:18 station2 kernel:  usbdev5.1_ep81: PM: suspend 0->1, parent 5-0:1.0 already 1
> Dec 22 14:22:18 station2 kernel:  usbdev4.1_ep81: PM: suspend 0->1, parent 4-0:1.0 already 1
> Dec 22 14:22:18 station2 kernel: ACPI: PCI interrupt for device 0000:01:07.2 disabled
> Dec 22 14:22:18 station2 kernel: ACPI: PCI interrupt for device 0000:01:07.1 disabled
> Dec 22 14:22:18 station2 kernel: ACPI: PCI interrupt for device 0000:01:07.0 disabled
> Dec 22 14:22:18 station2 kernel: NVRM: RmPowerManagement: 3
> Dec 22 14:22:18 station2 kernel: ACPI: PCI interrupt for device 0000:00:09.0 disabled
> Dec 22 14:22:18 station2 kernel: ACPI: PCI interrupt for device 0000:00:07.0 disabled
> Dec 22 14:22:18 station2 kernel: ACPI: PCI interrupt for device 0000:00:04.1 disabled
> Dec 22 14:22:18 station2 kernel: ACPI: PCI interrupt for device 0000:00:04.0 disabled
> Dec 22 14:22:18 station2 restorecond: Read error (Interrupted system call)
> Dec 22 14:22:19 station2 kernel: ACPI: PCI interrupt for device 0000:00:02.1 disabled
> Dec 22 14:22:19 station2 kernel: ACPI: PCI interrupt for device 0000:00:02.0 disabled
> Dec 22 14:22:19 station2 kernel: .......................
> Dec 22 14:22:19 station2 kernel: swsusp: Need to copy 67866 pages
> Dec 22 14:22:19 station2 kernel: Intel machine check architecture supported.
> Dec 22 14:22:19 station2 kernel: Intel machine check reporting enabled on CPU#0.
> Dec 22 14:22:19 station2 kernel: swsusp: Restoring Highmem
> Dec 22 14:22:19 station2 kernel: PCI: Enabling device 0000:00:02.0 (0000 -> 0002)
> Dec 22 14:22:19 station2 kernel: ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LUB0] -> GSI 21 (level, low) -> IRQ 66
> Dec 22 14:22:20 station2 kernel: PCI: Enabling device 0000:00:02.1 (0000 -> 0002)
> Dec 22 14:22:20 station2 kernel: ACPI: PCI Interrupt 0000:00:02.1[B] -> Link [LUB2] -> GSI 23 (level, low) -> IRQ 233
> Dec 22 14:22:21 station2 kernel: usb usb1: root hub lost power or was reset
> Dec 22 14:22:21 station2 kernel: ehci_hcd 0000:00:02.1: debug port 1
> Dec 22 14:22:21 station2 kernel: ehci_hcd 0000:00:02.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
> Dec 22 14:22:21 station2 kernel: PCI: Enabling device 0000:00:04.0 (0000 -> 0002)
> Dec 22 14:22:21 station2 kernel: ACPI: PCI Interrupt 0000:00:04.0[A] -> Link [UB11] -> GSI 20 (level, low) -> IRQ 74
> Dec 22 14:22:21 station2 kernel: PCI: Enabling device 0000:00:04.1 (0000 -> 0002)
> Dec 22 14:22:21 station2 kernel: ACPI: PCI Interrupt 0000:00:04.1[B] -> Link [UB12] -> GSI 22 (level, low) -> IRQ 50
> Dec 22 14:22:21 station2 kernel: usb usb2: root hub lost power or was reset
> Dec 22 14:22:21 station2 kernel: ehci_hcd 0000:00:04.1: debug port 1
> Dec 22 14:22:21 station2 kernel: ehci_hcd 0000:00:04.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
> Dec 22 14:22:21 station2 kernel: PCI: Enabling device 0000:00:07.0 (0000 -> 0002)
> Dec 22 14:22:21 station2 kernel: ACPI: PCI Interrupt 0000:00:07.0[A] -> Link [LAZA] -> GSI 20 (level, low) -> IRQ 74
> Dec 22 14:22:21 station2 kernel: ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LSA0] -> GSI 23 (level, low) -> IRQ 233
> Dec 22 14:22:21 station2 kernel: NVRM: RmPowerManagement: 5
> Dec 22 14:22:21 station2 kernel: PCI: Enabling device 0000:01:07.0 (0110 -> 0111)
> Dec 22 14:22:21 station2 kernel: ACPI: PCI Interrupt 0000:01:07.0[A] -> Link [LNKB] -> GSI 18 (level, low) -> IRQ 82
> Dec 22 14:22:21 station2 kernel: PCI: Enabling device 0000:01:07.1 (0110 -> 0111)
> Dec 22 14:22:21 station2 kernel: ACPI: PCI Interrupt 0000:01:07.1[B] -> Link [LNKC] -> GSI 17 (level, low) -> IRQ 90
> Dec 22 14:22:21 station2 kernel: PCI: Enabling device 0000:01:07.2 (0110 -> 0112)
> Dec 22 14:22:21 station2 kernel: ACPI: PCI Interrupt 0000:01:07.2[C] -> Link [LNKD] -> GSI 19 (level, low) -> IRQ 58
> Dec 22 14:22:21 station2 kernel: pnp: Failed to activate device 00:08.
> Dec 22 14:22:21 station2 kernel: ata4: SATA link down (SStatus 0 SControl 300)
> Dec 22 14:22:21 station2 kernel: Restarting tasks... done
> Dec 22 14:22:21 station2 kernel: Enabling non-boot CPUs ...
> Dec 22 14:22:21 station2 kernel: SMP alternatives: switching to SMP code
> Dec 22 14:22:21 station2 kernel: Booting processor 1/1 eip 3000
> Dec 22 14:22:21 station2 kernel: CPU 1 irqstacks, hard=c074d000 soft=c072d000
> Dec 22 14:22:21 station2 kernel: Initializing CPU#1
> Dec 22 14:22:21 station2 kernel: Calibrating delay using timer specific routine.. 2000.18 BogoMIPS (lpj=1000092)
> Dec 22 14:22:21 station2 kernel: CPU: Vendor unknown, using generic init.
> Dec 22 14:22:21 station2 kernel: CPU: Your system may be unstable.
> Dec 22 14:22:21 station2 kernel: CPU1: AuthenticAMD AMD Athlon(tm) 64 X2 Dual Core Processor 4800+ stepping 02
> Dec 22 14:22:21 station2 kernel: CPU1 is up
> Dec 22 14:22:21 station2 kernel: ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
> Dec 22 14:22:21 station2 kernel: ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
> Dec 22 14:22:21 station2 kernel: ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
> Dec 22 14:22:21 station2 kernel: ata2.00: configured for UDMA/133
> Dec 22 14:22:21 station2 kernel: SCSI device sdb: 312581808 512-byte hdwr sectors (160042 MB)
> Dec 22 14:22:21 station2 kernel: sdb: Write Protect is off
> Dec 22 14:22:21 station2 kernel: SCSI device sdb: drive cache: write back
> Dec 22 14:22:21 station2 kernel: ata3.00: configured for UDMA/133
> Dec 22 14:22:21 station2 kernel: SCSI device sdc: 312581808 512-byte hdwr sectors (160042 MB)
> Dec 22 14:22:21 station2 kernel: sdc: Write Protect is off
> Dec 22 14:22:22 station2 kernel: SCSI device sdc: drive cache: write back
> Dec 22 14:22:22 station2 kernel: ata1.00: configured for UDMA/133
> Dec 22 14:22:22 station2 kernel: SCSI device sda: 312581808 512-byte hdwr sectors (160042 MB)
> Dec 22 14:22:22 station2 kernel: sda: Write Protect is off
> Dec 22 14:22:22 station2 kernel: SCSI device sda: drive cache: write back
> Dec 22 14:22:22 station2 gnome-power-manager: (freedom) Resuming computer
> Dec 22 14:22:42 station2 ntpd[6599]: ntpd 4.2.2p1 at 1.1570-o Tue Jun 10 00:07:18 UTC 2008 (1)
> Dec 22 14:22:42 station2 ntpd[6600]: precision = 1.000 usec
> Dec 22 14:22:42 station2 ntpd[6600]: Listening on interface wildcard, 0.0.0.0#123 Disabled
> Dec 22 14:22:42 station2 ntpd[6600]: Listening on interface wildcard, ::#123 Disabled
> Dec 22 14:22:42 station2 ntpd[6600]: Listening on interface lo, ::1#123 Enabled
> Dec 22 14:22:42 station2 ntpd[6600]: Listening on interface eth0, fe80::21d:60ff:fe80:f35a#123 Enabled
> Dec 22 14:22:42 station2 ntpd[6600]: Listening on interface lo, 127.0.0.1#123 Enabled
> Dec 22 14:22:42 station2 ntpd[6600]: Listening on interface eth0, 192.168.1.2#123 Enabled
> Dec 22 14:22:42 station2 ntpd[6600]: kernel time sync status 0040
> Dec 22 14:22:44 station2 ntpd[6600]: frequency initialized -33.752 PPM from /var/lib/ntp/drift
>               

the only message i found in the list while searching was this :
http://lists.centos.org/pipermail/centos/2008-January/050910.html

googling i found some hints related to ubuntu to change some hibernation 
option in /etc/default/acpi-support but is there some file like that in 
CentOS 5.2 because when i do "sudo find / -name acpi-support" and 
supplying my normal user password it does not return anything.


More information about the CentOS mailing list