[CentOS] Anaconda ignores "cmdline" directive

Amos Shapira amos.shapira at gmail.com
Fri Jul 4 04:12:41 UTC 2008


Hello,

Our environment: CentOS 5.2 (updated over time with "yum update",
current "yum update" lists about 7 packages out of date), x86_64.
Running Xen, building Xen DomU's with kickstart.

We are trying to debug the %post part of the kickstart process for
DomU and are hitting difficulties in accessing the output.

For a start, the "cmdline" directive in the kickstart seems to be
ignored and it stays in "text" (ncurses) mode.

Here is the kickstart file we use:

install
url --url http://a.b.c.d/centos/5.2/os/x86_64
logging --level=debug
lang en_US.UTF-8
network --device eth0 --bootproto static --ip=a.b.c.e
--netmask=255.255.255.0 --gateway=a.b.c.f --nameserver=a.b.c.g
--hostname domu-hostname
rootpw --iscrypted $1$password
authconfig --enableshadow --enablemd5
selinux --disabled
timezone --utc Australia/Sydney
bootloader --location=mbr --driveorder=xvda --append="console=xvc0"
poweroff
cmdline
# Partitioning
zerombr
clearpart --all --initlabel --drives=xvda
part /boot --fstype ext3 --size=100 --ondisk=xvda
part pv.2 --size=0 --grow --ondisk=xvda
volgroup xxx --pesize=32768 pv.2
logvol / --fstype ext3 --name=root --vgname=xxx --size=1024 --grow
logvol swap --fstype swap --name=swap --vgname=xxx --size=256 --grow
--maxsize=512
%packages --nobase
wget
%post
set -x
echo hello world

Can anyone point what are we missing?

Googl'ing around just keeps coming up with pages saying that this
should work (e.g. "Running anaconda in real text-mode" and "Logging
%pre and %post" in http://wiki.centos.org/TipsAndTricks/KickStart) but
the problem so far still remains that Anaconda uses ncurses, not
"cmdline".

Thanks,

--Amos



More information about the CentOS mailing list