[CentOS] cvs command failure on 5.2

MHR mhullrich at gmail.com
Fri Jul 4 23:32:32 UTC 2008


Another little problem I am now having on CentOS 5.2 that I was not
seeing on FC8:

[mrichter at sushi lane]$ cvs update
poll: protocol failure in circuit setup
cvs [update aborted]: end of file from server (consult above messages if any)

I could understand if there was something that had changed from FC1 to
CentOS 5.2, but if it works in FC8, why not here?

Here's what's in the CVS directory and files:

[mrichter at sushi lane]$ ls CVS
Entries  Repository  Root  Tag
[mrichter at sushi lane]$ for i in CVS/*; do echo $i; cat $i; echo ""; done
CVS/Entries
/Makefile.template/1.2/Thu Oct  6 19:06:14 2005//TDEV_608
/makefile.include/2.6/Wed Dec  6 21:58:01 2006//TDEV_608
D/bin////
D/cron_jobs////
D/devices////
D/doc////
D/drivers////
D/include////
D/lanecon////
D/lib_src////
D/main////
D/parser////
D/sim////
D/tcautil////
D/viewcon////
D/webmon////
/Makefile/1.2/Fri Jul  4 23:22:10 2008//TDEV_608

CVS/Repository
linuxlane/lane

CVS/Root
khan:/home/stage/CVS

CVS/Tag
TDEV_608

(Khan is our main file server, and it's running a Linux that's even
older than FC1 - not sure what:

[mrichter at khan mrichter]$ uname -a
Linux khan 2.4.21-15.ELsmp #1 SMP Thu Apr 22 00:18:24 EDT 2004 i686
i686 i386 GNU/Linux

Our execution/test server is viper, with FC1:

[mrichter at viper lane]$ uname -a
Linux viper 2.4.23HZ_opt #12 Fri Apr 1 13:57:09 PST 2005 i686 i686
i386 GNU/Linux

What command tells me which distro I'm on?  I forget....)

I'm a little rusty on my cvs mastery (?) but most of this looks ok to
me, and, as I mentioned, it works in FC8, but not CentOS 5.2.

Any ideas/suggestions/etc?

Thanks.

mhr



More information about the CentOS mailing list