[CentOS] nspluginwrapper failure on x86_64 in 5.2

Mark Hull-Richter mhullrich at gmail.com
Sun Jul 6 16:01:28 UTC 2008


This was working in 5.1 - I am now getting errors when I try to run a
flash video in seamonkey under CetnOS 5.2.  Here is the error:

For application/x-shockwave-flash found plugin /usr/lib64/mozilla/plugins/npwrapper.libflashplayer.so
sh: /usr/lib/nspluginwrapper/i386/linux/npviewer: No such file or directory

Here is what I have installed:

$rpm -qa | grep -i nsplugin
nspluginwrapper-0.9.91.5-21.el5.i386
nspluginwrapper-0.9.91.5-21.el5.x86_64

These are now part of the base, but there seems to be a problem with
finding the right plugin to execute:


$ locate nspluginwrapper
/etc/sysconfig/nspluginwrapper
/usr/lib/nspluginwrapper
/usr/lib/nspluginwrapper/npconfig
/usr/lib/nspluginwrapper/npviewer
/usr/lib/nspluginwrapper/npviewer.bin
/usr/lib/nspluginwrapper/npwrapper.so
/usr/lib/nspluginwrapper/plugin-config
/usr/lib64/nspluginwrapper
/usr/lib64/nspluginwrapper/npconfig
/usr/lib64/nspluginwrapper/npviewer
/usr/lib64/nspluginwrapper/npviewer.bin
/usr/lib64/nspluginwrapper/npwrapper.so
/usr/lib64/nspluginwrapper/plugin-config
/usr/share/doc/nspluginwrapper-0.9.91.5
/usr/share/doc/nspluginwrapper-0.9.91.5/COPYING
/usr/share/doc/nspluginwrapper-0.9.91.5/NEWS
/usr/share/doc/nspluginwrapper-0.9.91.5/README
/var/cache/yum/base/packages/nspluginwrapper-0.9.91.5-21.el5.i386.rpm
/var/cache/yum/base/packages/nspluginwrapper-0.9.91.5-21.el5.x86_64.rpm

Just for good measure:

$ ls -R /usr/lib/nspluginwrapper
/usr/lib/nspluginwrapper:
npconfig*  npviewer*  npviewer.bin*  npwrapper.so*  plugin-config*

What happened (or, what do I do next)?  This seems to be broken in 5.2.

Thanks.

mhr





More information about the CentOS mailing list