[CentOS] nspluginwrapper failure on x86_64 in 5.2

MHR mhullrich at gmail.com
Sun Jul 6 20:13:29 UTC 2008


On Sun, Jul 6, 2008 at 9:48 AM, B.J. McClure <keepertoad at verizon.net> wrote:
>
>
> I have a similar issue with only one version of nspluginwrapper
> installed.
>        # rpm -qa | grep nspluginwrapper
> nspluginwrapper-0.9.91.5-21.el5
> I do appear to have two identical firefox packages installed.
>        # rpm -qa | grep firefox
> firefox-3.0-0.beta5.6.el5.centos
> firefox-3.0-0.beta5.6.el5.centos
>
> One is 32 bit, other 64 bit with identical package names.  How to remove
> unwanted package?

Add this to your .rpmmacros file:

%_query_all_fmt %%{name}-%%{version}-%%{release}.%%{arch}

Then remove the i386 version.

(You could just rmeove the i396 version, but it's nice to see the
differences when you list them, too.)

mhr



More information about the CentOS mailing list