[CentOS] USB not detected after update

Nicholas nicholas at oscc.org.my
Wed Jul 9 10:31:14 UTC 2008


Hi all,

currently on a lenovo R60, after upgrading the CentOS 5.1 I cant detect 
the USB device any more. The initial installation doesnt have any 
problems at all. Cannot find solution in forums and bugs either. I am 
not sure if its a bug or wrongly did an update. The lsusb did not show 
the device.

Things I did:

(1) updated to 2.6.18-53.1.21.el5 i686
then to 2.6.18-92.1.6.el5 i686
and here are some of the settings after update


(2) Ran  lsmod
ehci_hcd               33101  0
ohci_hcd               23261  0
uhci_hcd               25421  0

(3) Ran cat /proc/interrupts
           CPU0       CPU1      
  0:     204299          0    IO-APIC-edge  timer
  1:        208          0    IO-APIC-edge  i8042
  2:          0          0          XT-PIC  cascade
  8:          1          0    IO-APIC-edge  rtc
 11:          2          0    IO-APIC-edge  ehci_hcd:usb1, uhci_hcd:usb2,
uhci_hcd:usb3, uhci_hcd:usb4, uhci_hcd:usb5, HDA Intel, 
i915 at pci:0000:00:02.0
 12:       4782       3521    IO-APIC-edge  i8042
 14:       6429      11429    IO-APIC-edge  libata
 15:         27       1370    IO-APIC-edge  ide1
209:         27       2661         PCI-MSI  eth0
NMI:          0          0
LOC:     204143     204151
ERR:          0
MIS:          0


(4) When I plug in usb disk, the /var/log/messages shows

Jul  9 12:35:01 localhost kernel: usb 5-2: new high speed USB device 
using ehci_hcd and address 2
Jul  9 12:35:02 localhost kernel: ehci_hcd 0000:00:1d.7: Unlink after 
no-IRQ?  Controller is probably using the wrong IRQ.
Jul  9 12:35:12 localhost kernel: usb 5-2: device not accepting address 
2, error -110

(5) checked blacklist file, no usb devices like the ehci

Before going into CentOS 5.2, I need to verify what is the problem and 
if it will occur again.
 Any help on this?


--- 

Join OSCC MAMPU Mailing Lists
http://lists.oscc.org.my/mailman/listinfo/oscc-discuss





More information about the CentOS mailing list