[CentOS] yum dependency problem

fred smith fredex at fcshome.stoneham.ma.us
Thu Jul 10 02:13:23 UTC 2008


Hi:

Today when I do yum update I get this:

Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libdirectfb-0.9.so.25 for package: mplayer
---> Package directfb.i386 0:1.0.1-1.el5.rf set to be updated
---> Package amrnb.i386 0:7.0.0.2-1.el5.rf set to be updated
---> Package gsm.i386 0:1.0.12-1.el5.rf set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: libdirectfb-0.9.so.25 is needed by package mplayer

and I have to admit I don't understand that.... it says it's going to 
update directfb.i386 then it says directfb is required by mplayer. Huh?

perhaps it means it's trying to replace my existing directfb with a
DIFFERENT verson and can't because mplayer needs the existing one?
the existing directfb I have is:

	directfb-0.9.25.1-1.el5.rf

which came from the same repo as my mplayer:

	mplayer-1.0-0.38.rc1try2.el5.rf

so am I to assume that some other repo (with a greater priority, since
I'm using the priority plugin) is trying to overwrite the one I got
from the rf repo?

the base repos (base, updates, addons and extras) are all priority 1,
centosplus and contrib are 2. rpmforge is 10. that's all there are.
What's wrong here?

Thanks!
-- 
---- Fred Smith -- fredex at fcshome.stoneham.ma.us -----------------------------
                       I can do all things through Christ 
                              who strengthens me.
------------------------------ Philippians 4:13 -------------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20080709/c15b4bd8/attachment.bin


More information about the CentOS mailing list