[CentOS] Dual video card, 1 monitor each (ref dual head) CentoS4.6 xorg does only 1 head

William L. Maltby CentOS4Bill at triad.rr.com
Tue Jul 22 10:03:16 UTC 2008


I need to start running a dual head on one of my machines. Eventual
target is CentOS 5.x. Decided to test first on my 4.6 setup (eventually
it will achieve 5.x). Both machines are fully up to date.

The test machine is 4.6, 2 radeon video cards. Searched the web, CentOS
site, even bugzilla. This bugzilla entry from a 4.2 system),
http://bugs.centos.org/view.php?id=1875
had only a WFM response.

I've attached a gzipped text file of pertinent information.

Briefly, kudzu did the right thing when I installed the second card.
System-config-display also behaved correctly. X start ok, but will only
use one head at a time. Adding a second "BusID" so that both cards are
explicitly addressed didn't help. When the 2 "BusID" entries are
switched, the active screen doesn't move (it's always "Screen0") and the
ignored screen ("Screen1") remains the same. The monitor attached to the
video card for "Screen0" becomes the active one.

Q1: Anyone have a two video card CentOS 4.6 setup working?

Q2: Is it working in CentOS 5?

Q3: Anyone see something I'm doing wrong? Suggestions?

TIA,
-- 
Bill
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg_debug.txt.gz
Type: application/x-gzip
Size: 3693 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20080722/f931f5f0/xorg_debug.txt.bin


More information about the CentOS mailing list