[CentOS] Oracle apps form server issue with Piranha Load balancer

lingu hicheerup at gmail.com
Tue Jul 22 16:16:10 UTC 2008


Hi all,

   First of all sorry for writing such a big mail.I am facing problem while
implementing Piranha Load balancer on CENTOS 4 for my two oracle 11i
application server running on linux.

Oracle Real server details

Instance Name - test

url's -  1 . dev.xxx.com:8004
           2 . uat.xxx.com:8004

Architecture -
Services installed on dev are

1. Database Server
2.Concurrent Processing Server
3. Administration Server
4. Forms Server
5. Web server

And services installed on uat are

1.Web server
2.Form server

Note: Form server running on  port 9004 on both hosts.

Piranha details

eth0 192.168.23.2   --- external physical ip
eth0:1 192.168.23.3 ---EXTERNAL VIP
eth2  192.168.17.125 --internal physical ip
eth2:1 192.168.17.121 --INTERNAL VIP

Client Network: 192.168.23.0/24
Real Server Network: 192.168.17.0/24

 Client are accessing oracle application using VIP of piranha by
http://192.168.23.3:8004/

Real server ips, hostname and gateway

192.168.17.16    dev.xxx.com    having gateway of piranha Internal vip
192.168.17.121
192.168.17.17    uat.xxx.com        having gateway of piranha Internal vip
192.168.17.121

 my ipvsadm rule is like below

192.168.23.3:8004 ---->>192.168.17.16:8004
192.168.23.3:8004 ---->>192.168.17.17:8004

 For me load balancing is working fine for http://192.168.23.3:8004/ . But
once i logged in when ever i tried to browse any Oracle Application Forms
then it is giving me error "Failed to connect to the server" uat.
xxx.com:9004

Note: Form server running on port 9004 on my both oracle application sever

  when ever i click on any forms it is trying to connect to  uat.xxx.com[which
is aliased to the VIP of piranha that is 192.168.23.3 in my client host
entry] so it is clearly trying to connect to 192.168.23.3:9004 but  there is
no service or ipvsadm rule on that vip of piranha for that 9004 port.

Note: Telnet to Form server on both oracle apps server is working on 9004
from piranha server.

  So i created the ipvsadm rules on piranha on same vip on 9004 port like
below.
192.168.23.3:9004 ---->>192.168.17.16:9004
192.168.23.3:9004 ---->>192.168.17.17:9004

 But i am getting below error on my syslog

################################################################################
Jul 21 20:25:38 testlvs nanny[5064]: starting LVS client monitor for
192.168.23.3:9004
Jul 21 20:25:38 testlvs nanny[5065]: starting LVS client monitor for
192.168.23.3:9004
Jul 21 20:25:43 testlvs pulse[5040]: gratuitous lvs arps finished
Jul 21 20:25:47 testlvs nanny[5065]: READ from 192.168.17.16:9004 was too
short
Jul 21 20:25:47 testlvs nanny[5064]: READ from 192.168.17.17:9004 was too
short
Jul 21 20:25:53 testlvs nanny[5061]: making 192.168.17.16:8004 available
Jul 21 20:25:53 testlvs nanny[5065]: READ from 192.168.17.16:9004 was too
short
Jul 21 20:25:53 testlvs nanny[5059]: making 192.168.17.124:80 available
Jul 21 20:25:53 testlvs nanny[5062]: making 192.168.17.17:8004 available
Jul 21 20:25:53 testlvs nanny[5064]: READ from 192.168.17.17:9004 was too
short
Jul 21 20:25:59 testlvs nanny[5065]: READ from 192.168.17.16:9004 was too
short
Jul 21 20:25:59 testlvs nanny[5064]: READ from 192.168.17.17:9004 was too
short
Jul 21 20:26:05 testlvs nanny[5065]: READ from 192.168.17.16:9004 was too
short
Jul 21 20:26:05 testlvs nanny[5064]: READ from 192.168.17.17:9004 was too
short
Jul 21 20:26:11 testlvs nanny[5065]: READ from 192.168.17.16:9004 was too
short
Jul 21 20:26:11 testlvs nanny[5064]: READ from 192.168.17.17:9004 was too
short
Jul 21 20:26:17 testlvs nanny[5065]: READ from 192.168.17.16:9004 was too
short
Jul 21 20:26:17 testlvs nanny[5064]: READ from 192.168.17.17:9004 was too
short
Jul 21 20:26:23 testlvs nanny[5065]: READ from 192.168.17.16:9004 was too
short
################################################################################

  I am not able to see any thing for 9004 whenever i try ipvsdam -L. So i
need some one help to solve this issue,i am facing problem only with forms
rest of all of my other apps are working fine under piranha.Also forms are
working fine whenever i bypassed piranha server.


Regards,
lingu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20080722/170480dd/attachment.htm


More information about the CentOS mailing list