[CentOS] problems with update of perl-5.8.8-10.el5_2.3

Gregory P. Ennis PoMec at PoMec.Net
Sun Jul 27 13:30:09 UTC 2008


On Sat, 2008-07-26 at 22:45 -0500, Johnny Hughes wrote:
> Gregory P. Ennis wrote:
> > List,
> > 
> > I have an 2.6.18-92.1.6.el5xen X86_64 machine that is failing to update
> > perl.  I did not see any bugs reported on the list and was wondering if
> > anyone else had the same problem with a solution.
> > 
> > Thanks,
> > 
> > Greg Ennis
> > 
> > 
> > Updating:
> >  perl                    x86_64     4:5.8.8-10.el5_2.3  updates
> > 12 M
> > 
> > Transaction Summary
> > =============================================================================
> > Install      0 Package(s)
> > Update       1 Package(s)EcCare_uJ6786
> > Remove       0 Package(s)
> > 
> > Total download size: 12 M
> > Downloading Packages:
> > Running rpm_check_debug
> > Running Transaction Test
> > Finished Transaction Test
> > 
> > 
> > Transaction Check Error:
> >   file /usr/lib/perl5/5.8.8/pod/perldiag.pod from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/c2ph.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/cpan.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/dprofpp.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/enc2xs.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/find2perl.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/h2ph.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/h2xs.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/instmodsh.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/libnetcfg.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/perlbug.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/perlcc.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/perldiag.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/perlivp.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/piconv.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/pl2pm.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/pod2html.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/pod2latex.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/pod2man.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/pod2text.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/pod2usage.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/podchecker.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/podselect.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/prove.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/psed.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/pstruct.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/s2p.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/splain.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> >   file /usr/share/man/man1/xsubpp.1.gz from install of
> > perl-5.8.8-10.el5_2.3 conflicts with file from package
> > perl-5.8.8-10.el5_0.2
> 
> looks like you have both perl i386 and x86_64 installed ... do you need 
> both?
> 
> If so, make sure extras is also enabled.
> 
> 

I don't believe both are needed; I think it was installed for some items
related to spamassassin that required it.  Thanks for your help !!!!



More information about the CentOS mailing list