[CentOS] Printing to remote usb printer

Anne Wilson cannewilson at googlemail.com
Mon Jun 2 18:27:42 UTC 2008


My networked printer has developed a fault and has to be returned to the 
manufacturer, so I have to go back to a usb printer attached to my file 
server.  In the past I worked happily with a remote printer, but I'm having 
no success at all today, and could do with some prompting.

/var/log/cups/error_log says:

I [02/Jun/2008:17:02:21 +0100] [Job 276] Adding start banner page "none".
I [02/Jun/2008:17:02:21 +0100] [Job 276] Adding job file of type 
application/postscript.
I [02/Jun/2008:17:02:21 +0100] [Job 276] Adding end banner page "none".
I [02/Jun/2008:17:02:21 +0100] [Job 276] Queued on "HPDesJet990C" by "anne".
I [02/Jun/2008:17:02:21 +0100] [Job 276] Started 
filter /usr/lib/cups/filter/pstops (PID 21331)
I [02/Jun/2008:17:02:21 +0100] [Job 276] Started 
filter /usr/lib/cups/filter/foomatic-rip (PID 21332)
I [02/Jun/2008:17:02:21 +0100] [Job 276] Started 
backend /usr/lib/cups/backend/smb (PID 21333)
I [02/Jun/2008:17:02:27 +0100] [Job 276] Completed successfully.

That sounds fine, but nothing came out of the printer.

Excerpt from /var/log/cups/access_log:

 localhost - - [02/Jun/2008:17:02:20 +0100] "POST / HTTP/1.1" 200 207 
Get-Printer-Attributes successful-ok
localhost - - [02/Jun/2008:17:02:20 +0100] "GET /ppd/HPDesJet990C.ppd 
HTTP/1.1" 200 23033 - -
localhost - - [02/Jun/2008:17:02:20 +0100] "POST /printers/HPDesJet990C 
HTTP/1.1" 200 573690 Print-Job successful-ok
localhost - - [02/Jun/2008:17:02:22 +0100] "POST /printers/ HTTP/1.1" 200 253 
CUPS-Get-Printers successful-ok
localhost - - [02/Jun/2008:17:02:22 +0100] "POST /classes/ HTTP/1.1" 200 224 
CUPS-Get-Classes successful-ok
localhost - - [02/Jun/2008:17:02:22 +0100] "POST /printers/ HTTP/1.1" 200 112 
CUPS-Get-Default successful-ok
localhost - - [02/Jun/2008:17:02:22 +0100] "POST / HTTP/1.1" 200 381 Get-Jobs 
successful-ok
localhost - - [02/Jun/2008:17:02:22 +0100] "POST /printers/ HTTP/1.1" 200 253 
CUPS-Get-Printers successful-ok
localhost - - [02/Jun/2008:17:02:22 +0100] "POST /classes/ HTTP/1.1" 200 224 
CUPS-Get-Classes successful-ok
localhost - - [02/Jun/2008:17:02:22 +0100] "POST /printers/ HTTP/1.1" 200 112 
CUPS-Get-Default successful-ok
localhost - - [02/Jun/2008:17:02:22 +0100] "POST / HTTP/1.1" 200 381 Get-Jobs 
successful-ok
localhost - - [02/Jun/2008:17:02:27 +0100] "POST /printers/ HTTP/1.1" 200 253 
CUPS-Get-Printers successful-ok
localhost - - [02/Jun/2008:17:02:27 +0100] "POST /classes/ HTTP/1.1" 200 224 
CUPS-Get-Classes successful-ok
localhost - - [02/Jun/2008:17:02:27 +0100] "POST /printers/ HTTP/1.1" 200 112 
CUPS-Get-Default successful-ok
localhost - - [02/Jun/2008:17:02:27 +0100] "POST / HTTP/1.1" 200 381 Get-Jobs 
successful-ok

The server runs CentOS 5.1 and the client laptop runs Mandriva 2008.  I have 
tried both the cups page and Mandriva's printerdrake to set this up, so there 
is the possibility of conflicts introduced by warring tools.

I don't recall having to perform somersaults to get this to work before, but 
it's a major PITA to be so restricted in where I can print, so I'd welcome 
hints about where to look next.  Thanks

Anne
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : http://lists.centos.org/pipermail/centos/attachments/20080602/f8e6c4d2/attachment.bin


More information about the CentOS mailing list