[CentOS] LDAP syncrepl incompatibility between CentOS 4.x and 5.x

Ralph Angenendt ra+centos at br-online.de
Wed Jun 11 22:36:00 UTC 2008


Craig White wrote:
> On Thu, 2008-06-12 at 00:08 +0200, Ralph Angenendt wrote:
> > I tried to do that, as I wanted to have LDAP overlays (hey, anyone who
> > wants to test those on CentOS 5 - there are packages in the testing
> > repository).
> > 
> > And I found out that you don't want to do that. There are too many
> > packages which are built against openldap, you'd end up rebuilding a
> > rather large part of the distribution. 
> ----
> IIRC, you have to build from source...
> - openssl
> - kerberos
> - cyrus-sasl
> - db4
> - openldap
> 
> I built everything in /usr/local and just left the distribution packages
> intact and it worked.

On my CentOS 5 install there are about 33 packages requiring a certain
version of libldap and liblber.

Ralph
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20080612/7fd6d843/attachment.bin


More information about the CentOS mailing list