[CentOS] can't install software, "not using ftp, http[s], or file for repos, skipping - 5 is not a valid release or hasnt been released yet"

Rudi Ahlers Rudi at SoftDux.com
Thu Jun 19 16:30:29 UTC 2008


Hi all

I've just installed CentOS 5.1 x64, from the 1st CD (minimal 
installation) and then tried to install Apache, but keep on getting this 
error:

[root at cacti ~]# yum install apache
Loading "installonlyn" plugin
Repository centosplus is listed more than once in the configuration
Setting up Install Process
Setting up repositories
not using ftp, http[s], or file for repos, skipping - 5 is not a valid 
release or hasnt been released yet
not using ftp, http[s], or file for repos, skipping - 5 is not a valid 
release or hasnt been released yet
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do



Some extra info:

rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}.rpm\n" '*yum*'
yum-metadata-parser-1.0-8.fc6.x86_64.rpm
yum-3.0.5-1.el5.centos.5.noarch.rpm
yum-updatesd-3.0.5-1.el5.centos.5.noarch.rpm


Doing a "yum upgrade", I got this:

Dependency Installed: perl-Crypt-PasswdMD5.noarch 0:1.3-1.2.el5.rf 
perl-Digest-SHA1.x86_64 0:2.11-1.2.1
Updated: lftp.x86_64 0:3.7.3-1.el5.rf mtr.x86_64 2:0.72-1.el5.rf 
rsync.x86_64 0:3.0.2-1.el5.rf syslinux.x86_64 0:3.63-1.el5.rf
Complete!


Does anyone know how to fix this?




-- 

Kind Regards
Rudi Ahlers
CEO, SoftDux

Web:   http://www.SoftDux.com
Check out my technical blog, http://blog.softdux.com for Linux or other technical stuff, or visit http://www.WebHostingTalk.co.za for Web Hosting stuff




More information about the CentOS mailing list