[CentOS] SATA errors on CentOS 5.2

MHR mhullrich at gmail.com
Tue Nov 4 00:41:00 UTC 2008


We have a new machine here that we are trying to use for CentOS as a
base for our primary application.  Although I do not have direct
access to the physical machine, I have begun looking into it remotely
(via ssh) to see why we are getting the following errors periodically:

/var/log/messages.1-Nov  1 18:19:00 Centos5 kernel: hda: status
timeout: status=0xd0 { Busy }
/var/log/messages.1:Nov  1 18:19:00 Centos5 kernel: ide: failed opcode
was: unknown
/var/log/messages.1-Nov  1 18:19:00 Centos5 kernel: hda: no DRQ after
issuing MULTWRITE_EXT
/var/log/messages.1-Nov  1 18:19:00 Centos5 kernel: ide0: reset: success

This happened 12 times (at least) in the last four days, and it
(reportedly) does not occur if FC9 is booted on that machine.

The machine is configured as follows:

Pentium Core 2 Duo at 3.4GHz, 1GB RAM
Intel m/b, not sure exactly which one, but here's what lspci shows:

00:00.0 Host bridge: Intel Corporation 82Q963/Q965 Memory Controller
Hub (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965
Integrated Graphics Controller (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB
UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB
UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2
EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio
Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express
Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express
Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express
Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB
UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB
UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB
UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2
EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HO (ICH8DO) LPC Interface
Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port
SATA IDE Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port
SATA IDE Controller (rev 02)
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet
Controller
03:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet
Controller
04:0c.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
04:0d.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
04:0e.0 Communication controller: Comtrol Corporation RocketPort 16
port w/external I/F (rev 04)
04:0f.0 Non-VGA unclassified device: PLX Technology, Inc. PCI <->
IOBus Bridge (rev 01)

The disk is a Seagate ST3250310NS (250GB) with an 8G /boot, 65G / and
160G /usr, with 2 2G swap partitions in the extended partition (!).

(Seagate - I smell trouble, but, as I said, FC9 doesn't do this at all.)

uname -a returns Linux Centos5.2SATAMaster 2.6.18-92.1.13.el5 #1 SMP
Wed Sep 24 19:33:52 EDT 2008 i686 i686 i386 GNU/Linux.

I've run the smartctl utility, and it shows no errors.

What am I missing?  Is it odd to have two SATA controllers for a
single disk drive, or is that at all relevant?

Thanks.

mhr


More information about the CentOS mailing list