[CentOS] gem ruby-sqlite3 install error

Matthew Kent matt at bravenet.com
Wed Nov 12 22:36:16 UTC 2008


On Wed, 2008-11-12 at 21:44 +0000, ponto wrote:
> i am tryin' to install ruby-sqlite3 via gem, but it keeps givin' me
> this output:
> 
> mathilda ~ # gem install sqlite3-ruby
> Building native extensions. This could take a while...
> ERROR: Error installing sqlite3-ruby:
> ERROR: Failed to build gem native extension.
> 
> /usr/bin/ruby extconf.rb install sqlite3-ruby
> checking for fdatasync() in -lrt... no
> checking for sqlite3.h... no
> 
> make
> make: *** No rule to make target `ruby.h', needed by
> `sqlite3_api_wrap.o'. Stop.

>From the output and the rpms you listed I'm not sure whats missing but
if you can due without it being a gem I successfully recompiled this
version from fedora 8 a while ago for CentOS 5.2:

http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/source/SRPMS/ruby-sqlite3-1.2.1-1.fc8.src.rpm 

Only BuildRequires I see there which you may want to check for is
'swig'.
-- 
Matthew Kent \ SA \ bravenet.com



More information about the CentOS mailing list