[CentOS] New installation woes

Dag Wieers dag at centos.org
Wed Nov 19 14:23:56 UTC 2008


On Wed, 19 Nov 2008, Kai Schaetzl wrote:

> Ralph Angenendt wrote on Wed, 19 Nov 2008 13:27:24 +0100:
>
>> You seem to have the rpmforge repository installed, because the package
>> in the base repositories is called perl-DBD-MySQL (note the mixed case
>> MySQL).
>
> and got replaced because the default install of yum-priorities doesn't
> check_obsoletes. base package perl-DBD-MySQL was indeed obsoleted by the
> rpmforge perl-DBD-mysql a few weeks ago. I fear a lot of people got caught
> by this without guard. I wonder why rpmforge did this.

We did not do anything. It is a bug in the priorities plugin.

The reason we have a perl-DBD-mysql is because that is the upstream name 
and the naming convention dictates to use the upstream name. That is the 
only reliable way for not having RPM clashes.

Maybe someone should report to Red Hat that perl-DBD-MySQL has a packaging 
bug ?

 	http://search.cpan.org/dist/DBD-mysql/

-- 
--   dag wieers,  dag at centos.org,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]


More information about the CentOS mailing list