[CentOS] Configuring an Intel 3945 wireless card: partial success

Niki Kovacs contact at kikinovak.net
Wed Sep 3 14:55:05 UTC 2008


Mogens Kjaer a écrit :
> 
> Take a close look at what gets logged into /var/log/messages
> 

Sorry couldn't try this out earlier, as my wife went away for a few days 
with the laptop.

Anyway, here goes. To try it out, I stopped the 'network' service and 
started 'NetworkManager' as well as 'NetworkManagerDispatcher'. Laptop 
was not connected to any Ethernet cable. My home access point showed up 
(essid 'zuhause', no encryption). I clicked on it to try to establish a 
connection:

--8<----------------------------------------------------------------
[root at nordinou init.d]# tail -f /var/log/messages
Sep  3 16:32:39 nordinou NetworkManager: <information>  User Switch: 
/org/freedesktop/NetworkManager/Devices/eth1 / zuhause
Sep  3 16:32:39 nordinou NetworkManager: <information>  Deactivating 
device eth1.
Sep  3 16:32:39 nordinou dhcdbd: message_handler: message handler not 
found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason
Sep  3 16:32:39 nordinou NetworkManager: <information>  Device eth1 
activation scheduled...
Sep  3 16:32:39 nordinou NetworkManager: <information>  Activation 
(eth1) started...
Sep  3 16:32:39 nordinou NetworkManager: <information>  Activation 
(eth1) Stage 1 of 5 (Device Prepare) scheduled...
Sep  3 16:32:39 nordinou NetworkManager: <information>  Activation 
(eth1) Stage 1 of 5 (Device Prepare) started...
Sep  3 16:32:39 nordinou NetworkManager: <information>  Activation 
(eth1) Stage 2 of 5 (Device Configure) scheduled...
Sep  3 16:32:39 nordinou NetworkManager: <information>  Activation 
(eth1) Stage 1 of 5 (Device Prepare) complete.
Sep  3 16:32:39 nordinou NetworkManager: <information>  Activation 
(eth1) Stage 2 of 5 (Device Configure) starting...
Sep  3 16:32:39 nordinou NetworkManager: <information>  Activation 
(eth1/wireless): access point 'zuhause' is unencrypted, no key needed.
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: sending 
command 'INTERFACE_ADD eth1                wext 
/var/run/wpa_supplicant       '
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: sending 
command 'AP_SCAN 1'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: sending 
command 'ADD_NETWORK'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: response 
was '0'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: sending 
command 'SET_NETWORK 0 ssid 7a756861757365'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: sending 
command 'SET_NETWORK 0 key_mgmt NONE'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: sending 
command 'ENABLE_NETWORK 0'
Sep  3 16:32:39 nordinou NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:32:39 nordinou NetworkManager: <information>  Activation 
(eth1) Stage 2 of 5 (Device Configure) complete.
Sep  3 16:33:19 nordinou NetworkManager: <information>  Activation 
(eth1/wireless): association took too long (>40s), failing activation.
Sep  3 16:33:19 nordinou NetworkManager: <information>  Activation 
(eth1) failure scheduled...
Sep  3 16:33:19 nordinou NetworkManager: <information>  Activation 
(eth1) failed for access point (zuhause)
Sep  3 16:33:19 nordinou NetworkManager: <information>  Activation 
(eth1) failed.
Sep  3 16:33:19 nordinou NetworkManager: <information>  Deactivating 
device eth1.
--8<----------------------------------------------------------------

Now I was curious about this, so I tried it on another machine, my 
Buildbox, that also has a wireless card. Similar failure:

--8<----------------------------------------------------------------
[root at buildbox ~]# tail -f /var/log/messages
Sep  3 16:35:52 buildbox dhcdbd: Started up.
Sep  3 16:35:53 buildbox NetworkManager: <information>  starting...
Sep  3 16:35:53 buildbox NetworkManager: <WARNING> 
nm_system_device_get_system_config (): Network configuration for device 
'wlan0' was invalid (non-DHCP configuration, but no gateway specified. 
Will use DHCP instead.
Sep  3 16:35:53 buildbox NetworkManager: <information>  wlan0: Device is 
fully-supported using driver 'rt61'.
Sep  3 16:35:53 buildbox NetworkManager: <information>  wlan0: driver 
does not support SSID scans (scan_capa 0x00).
Sep  3 16:35:53 buildbox NetworkManager: <information> 
nm_device_init(): waiting for device's worker thread to start
Sep  3 16:35:53 buildbox NetworkManager: <information> 
nm_device_init(): device's worker thread started, continuing.
Sep  3 16:35:53 buildbox NetworkManager: <information>  Now managing 
wireless (802.11) device 'wlan0'.
Sep  3 16:35:53 buildbox NetworkManager: <information>  Deactivating 
device wlan0.
Sep  3 16:35:53 buildbox kernel: eth0: link down
Sep  3 16:35:53 buildbox kernel: ADDRCONF(NETDEV_UP): eth0: link is not 
ready
Sep  3 16:35:53 buildbox NetworkManager: <information>  eth0: Device is 
fully-supported using driver '8139too'.
Sep  3 16:35:53 buildbox NetworkManager: <information> 
nm_device_init(): waiting for device's worker thread to start
Sep  3 16:35:53 buildbox NetworkManager: <information> 
nm_device_init(): device's worker thread started, continuing.
Sep  3 16:35:53 buildbox NetworkManager: <information>  Now managing 
wired Ethernet (802.3) device 'eth0'.
Sep  3 16:35:53 buildbox NetworkManager: <information>  Deactivating 
device eth0.
Sep  3 16:35:53 buildbox NetworkManager: <information>  Updating allowed 
wireless network lists.
Sep  3 16:35:53 buildbox NetworkManager: <WARNING> 
nm_dbus_get_networks_cb (): error received: 
org.freedesktop.NetworkManagerInfo.NoNetworks - There are no wireless 
networks stored..
Sep  3 16:35:53 buildbox NetworkManager: <information>  SWITCH: no 
current connection, found better connection 'eth0'.
Sep  3 16:35:54 buildbox dhcdbd: message_handler: message handler not 
found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.reason
Sep  3 16:35:54 buildbox NetworkManager: <information>  Will activate 
wired connection 'eth0' because it now has a link.
Sep  3 16:35:54 buildbox dhcdbd: message_handler: message handler not 
found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.reason
Sep  3 16:35:54 buildbox NetworkManager: <information>  Will activate 
connection 'eth0'.
Sep  3 16:35:54 buildbox NetworkManager: <information>  Device eth0 
activation scheduled...
Sep  3 16:35:54 buildbox NetworkManager: <information>  Activation 
(eth0) started...
Sep  3 16:35:54 buildbox NetworkManager: <information>  Activation 
(eth0) Stage 1 of 5 (Device Prepare) scheduled...
Sep  3 16:35:54 buildbox NetworkManager: <information>  Activation 
(eth0) Stage 1 of 5 (Device Prepare) started...
Sep  3 16:35:54 buildbox NetworkManager: <information>  Activation 
(eth0) failure scheduled...
Sep  3 16:35:54 buildbox NetworkManager: <information>  Activation 
(eth0) Stage 1 of 5 (Device Prepare) complete.
Sep  3 16:35:54 buildbox NetworkManager: <information>  Activation 
(eth0) failed.
Sep  3 16:35:54 buildbox NetworkManager: <information>  Deactivating 
device eth0.
Sep  3 16:36:48 buildbox NetworkManager: <information>  User Switch: 
/org/freedesktop/NetworkManager/Devices/wlan0 / zuhause
Sep  3 16:36:48 buildbox NetworkManager: <information>  Deactivating 
device wlan0.
Sep  3 16:36:48 buildbox dhcdbd: message_handler: message handler not 
found under /com/redhat/dhcp/wlan0 for sub-path wlan0.dbus.get.reason
Sep  3 16:36:48 buildbox NetworkManager: <information>  Device wlan0 
activation scheduled...
Sep  3 16:36:48 buildbox NetworkManager: <information>  Activation 
(wlan0) started...
Sep  3 16:36:48 buildbox NetworkManager: <information>  Activation 
(wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Sep  3 16:36:48 buildbox NetworkManager: <information>  Activation 
(wlan0) Stage 1 of 5 (Device Prepare) started...
Sep  3 16:36:48 buildbox NetworkManager: <information>  Activation 
(wlan0) Stage 2 of 5 (Device Configure) scheduled...
Sep  3 16:36:48 buildbox NetworkManager: <information>  Activation 
(wlan0) Stage 1 of 5 (Device Prepare) complete.
Sep  3 16:36:48 buildbox NetworkManager: <information>  Activation 
(wlan0) Stage 2 of 5 (Device Configure) starting...
Sep  3 16:36:48 buildbox NetworkManager: <information>  Activation 
(wlan0/wireless): access point 'zuhause' is unencrypted, no key needed.
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: sending 
command 'INTERFACE_ADD wlan0               wext 
/var/run/wpa_supplicant '
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: sending 
command 'AP_SCAN 2'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: sending 
command 'ADD_NETWORK'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: response 
was '0'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: sending 
command 'SET_NETWORK 0 ssid 7a756861757365'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: sending 
command 'SET_NETWORK 0 key_mgmt NONE'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: sending 
command 'ENABLE_NETWORK 0'
Sep  3 16:36:48 buildbox NetworkManager: <information>  SUP: response 
was 'OK'
Sep  3 16:36:48 buildbox NetworkManager: <information>  Activation 
(wlan0) Stage 2 of 5 (Device Configure) complete.
Sep  3 16:37:08 buildbox NetworkManager: <information>  Activation 
(wlan0/wireless): association took too long (>20s), failing activation.
Sep  3 16:37:08 buildbox NetworkManager: <information>  Activation 
(wlan0) failure scheduled...
Sep  3 16:37:08 buildbox NetworkManager: <information>  Activation 
(wlan0) failed for access point (zuhause)
Sep  3 16:37:08 buildbox NetworkManager: <information>  Activation 
(wlan0) failed.
Sep  3 16:37:08 buildbox NetworkManager: <information>  Deactivating 
device wlan0.
--8<----------------------------------------------------------------

Any idea why NetworkManager refuses to connect to my network?

Niki






More information about the CentOS mailing list