[CentOS] Remove old kernel

Filipe Brandenburger filbranden at gmail.com
Sat Sep 6 00:05:44 UTC 2008


On Fri, Sep 5, 2008 at 20:00, Ed Donahue <liberaled at gmail.com> wrote:
> I've switched from the xen kernel to regular kernel and trying to remove the
> xen one is giving me an error:
>
> [root@ ~]# rpm -e kernel-xen-2.6.18-92.1.10.el5
> error: Failed dependencies:
>         xen-hypervisor-abi = 3.1 is needed by (installed)
> xen-3.0.3-64.el5_2.1.i686

This means you have to uninstall the "xen" package before you can
uninstall "kernel-xen".

HTH,
Filipe


More information about the CentOS mailing list