[CentOS] Kernel source - linux -2.6.18 i386 or i686

Robert Moskowitz rgm at htt-consult.com
Tue Sep 16 15:37:35 UTC 2008


Akemi Yagi wrote:
> On Tue, Sep 16, 2008 at 8:15 AM, Akemi Yagi <amyagi at gmail.com> wrote:
>   
>> Now I remember this one.  I believe you got this one answered that
>> time.  The patch cannot be directly applied to the CentOS kernel
>> because it was written for the vanilla kernel.
>>     
>
> Not just vanilla kernel but rather "more recent or newer kernel".
No. It was written for the 2.6.18 kernel. But I think it was written a 
few patches back. The patch author has a patch for pretty much all the 
kernels up to 2.6.26, as BEET is now officially in 2.6.27. But my first 
hunch was that he did this for the 2.6.18 kernel in FC6 that does not 
have all the patches that are in RHEL 5.2 (and thus Centos 5.2), and so 
his patches were off.

Then last night I thought, well there are these two directories under 
kernel-2.6.18 and which one is being used? Now I see that I had used 
both of them and it made no difference. Thus going back to my earlier 
thoughts about being a patch for this kernel, but not at the patch-point 
this kernel is at.

I have found a number of problems with the HIPL code that the developers 
are working to correct. I think becuase they had gotten focused on HIP 
over IPv4 and had let the IPv6 side slide a bit. The NETBSD developers 
claim that their code is ready, but that would be a bigger switch for me 
than going to FC8 where most of the HIPL development is being done...




More information about the CentOS mailing list