[CentOS] usb irq problem

partha chowdhury kira.laucas at gmail.com
Fri Sep 19 09:03:38 UTC 2008


hallo to all .

This is my first post to this list so please bare with me if i have made
any mistake .

My problem is :

after every boot i receive the following message in terminal :


> Sep 19 13:13:02 station2 kernel: irq 50: nobody cared (try booting with the "irqpoll" option)
> Sep 19 13:13:02 station2 kernel:  [<c044e6fa>] __report_bad_irq+0x2b/0x69
> Sep 19 13:13:02 station2 kernel:  [<c044e8e7>] note_interrupt+0x1af/0x1e8
> Sep 19 13:13:02 station2 kernel:  [<c057afb4>] usb_hcd_irq+0x23/0x50
> Sep 19 13:13:02 station2 kernel:  [<c044df27>] handle_IRQ_event+0x23/0x49
> Sep 19 13:13:02 station2 kernel:  [<c044dfe8>] __do_IRQ+0x9b/0xd6
> Sep 19 13:13:02 station2 kernel:  [<c04073f4>] do_IRQ+0x93/0xae
> Sep 19 13:13:02 station2 kernel:  [<c040592e>] common_interrupt+0x1a/0x20
> Sep 19 13:13:02 station2 kernel:  =======================
> Sep 19 13:13:02 station2 kernel: handlers:
> Sep 19 13:13:02 station2 kernel: [<c057af91>] (usb_hcd_irq+0x0/0x50)
> Sep 19 13:13:02 station2 kernel: Disabling IRQ #5


And immediately after it my external usb drive vanishes from the nautilus file browser and i get messages like this in /var/log/messages :


> usb 2-2: device not accepting address 3, error -110
> Sep 19 14:15:09 station2 kernel: usb 2-2: new high speed USB device using ehci_hcd and address 4
> Sep 19 14:15:21 station2 kernel: usb 2-2: device not accepting address 4, error -110
> Sep 19 14:15:21 station2 kernel: usb 2-2: new high speed USB device using ehci_hcd and address 5
> Sep 19 14:15:31 station2 kernel: usb 2-2: device not accepting address 5, error -110
> Sep 19 14:15:31 station2 kernel: usb 2-2: new high speed USB device using ehci_hcd and address 6
> Sep 19 14:15:42 station2 kernel: usb 2-2: device not accepting address 6, error -110
> Sep 19 14:16:48 station2 kernel: usb 2-4: new high speed USB device using ehci_hcd and address 7
> Sep 19 14:17:00 station2 kernel: usb 2-4: device not accepting address 7, error -110
> Sep 19 14:17:00 station2 kernel: usb 2-4: new high speed USB device using ehci_hcd and address 8
> Sep 19 14:17:11 station2 kernel: usb 2-4: device not accepting address 8, error -110
> 

and the usb drive does not show up in nautilus any more. Then i have to reboot and after logging into x the drive shows up .but again after some time the same thing happens.

please help.

i don't know if i have given enough information.so please tell me if any more info is needed.

Thanks.



More information about the CentOS mailing list