[CentOS] Update troubles for wxGTK apps

Niki Kovacs contact at kikinovak.net
Fri Sep 19 18:02:00 UTC 2008


Hi,

I have a CentOS 5.2 desktop with the RPMForge repo enabled. I just ran 
'yum update', and there seems to be some trouble with the wxGTK apps. A 
simple 'yum update' gives this error message:

--8<--------------------------------------------------------------------
--> Finished Dependency Resolution
Error: Missing Dependency: libwx_gtk2u_adv-2.6.so.0 is needed by package 
audacity
Error: Missing Dependency: libwx_gtk2u_xrc-2.6.so.0 is needed by package 
audacity
Error: Missing Dependency: libwx_gtk2u_html-2.6.so.0(WXU_2.6) is needed 
by package audacity
Error: Missing Dependency: libwx_gtk2u_html-2.6.so.0 is needed by 
package audacity
Error: Missing Dependency: libwx_baseu_net-2.6.so.0(WXU_2.6) is needed 
by package audacity
Error: Missing Dependency: libwx_baseu-2.6.so.0 is needed by package 
audacity
Error: Missing Dependency: libwx_gtk2u_qa-2.6.so.0 is needed by package 
audacity
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6) is needed 
by package audacity
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.2) is 
needed by package audacity
Error: Missing Dependency: libwx_baseu-2.6.so.0(WXU_2.6) is needed by 
package audacity
Error: Missing Dependency: libwx_baseu_net-2.6.so.0 is needed by package 
audacity
Error: Missing Dependency: libwx_gtk2u_core-2.6.so.0 is needed by 
package audacity
Error: Missing Dependency: libwx_baseu_xml-2.6.so.0 is needed by package 
audacity
--8<--------------------------------------------------------------------

But when I put an exclude line in /etc/yum.conf for wxGTK, the error 
message becomes:

--8<--------------------------------------------------------------------
Error: Missing Dependency: libwx_baseu-2.8.so.0 is needed by package amule
Error: Missing Dependency: libwx_baseu-2.8.so.0(WXU_2.8) is needed by 
package amule
Error: Missing Dependency: libwx_gtk2u_richtext-2.8.so.0 is needed by 
package vlc
Error: Missing Dependency: libwx_gtk2u_adv-2.8.so.0 is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_adv-2.8.so.0(WXU_2.8) is needed 
by package vlc
Error: Missing Dependency: libwx_baseu-2.8.so.0 is needed by package vlc
Error: Missing Dependency: libwx_baseu-2.8.so.0(WXU_2.8) is needed by 
package vlc
Error: Missing Dependency: libwx_gtk2u_aui-2.8.so.0 is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8) is needed 
by package vlc
Error: Missing Dependency: libwx_baseu_net-2.8.so.0 is needed by package 
amule
Error: Missing Dependency: libwx_gtk2u_adv-2.8.so.0(WXU_2.8) is needed 
by package amule
Error: Missing Dependency: libwx_baseu_net-2.8.so.0 is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_qa-2.8.so.0 is needed by package vlc
Error: Missing Dependency: libwx_baseu_xml-2.8.so.0 is needed by package vlc
Error: Missing Dependency: libwx_baseu_net-2.8.so.0(WXU_2.8) is needed 
by package amule
Error: Missing Dependency: libwx_gtk2u_core-2.8.so.0 is needed by 
package amule
Error: Missing Dependency: libwx_gtk2u_adv-2.8.so.0 is needed by package 
amule
Error: Missing Dependency: libwx_gtk2u_html-2.8.so.0 is needed by 
package vlc
Error: Missing Dependency: libwx_gtk2u_core-2.8.so.0(WXU_2.8) is needed 
by package amule
Error: Missing Dependency: libwx_gtk2u_xrc-2.8.so.0 is needed by package vlc
Error: Missing Dependency: libwx_gtk2u_core-2.8.so.0 is needed by 
package vlc
--8<--------------------------------------------------------------------

So it looks like Audacity depends on wxGTK 2.6, whereas Amule and VLC 
depend on wxGTK 2.8.

1) Where do I report a bug for that?

2) In the meantime, what can I do? Simply exclude vlc, amule, audacity 
and wxGTK from updates in /etc/yum.conf and wait until the problem is 
resolved?

Cheers,

Niki Kovacs


More information about the CentOS mailing list