[CentOS] building php4 against stock mysql on centos 5.2 64bit

Ivan Levchenko levchenko.i at gmail.com
Mon Sep 22 14:21:59 UTC 2008


HI,

I'm building php4.4.9 on centos 5.2 x64, and I need it to use the
systems mysql libs, not the bundled ones....

./configure --with-libdir=lib64 --with-dbx --with-openssl --with-pcre
--with-pgsql --with-posix \
--with-xml --with-zlib --with-gd=/usr --enable-gd-native-ttf
--enable-bcmath --enable-fastcgi \
--disable-ipv6 --enable-force-cgi-redirect --with-bz2 --enable-ftp
--with-apxs2 --with-iconv \
--with-freetype-dir=/usr --with-ttf --with-jpeg-dir=/usr
--with-xpm-dir=/usr --with-png \
--with-mysql=/usr --prefix=/usr/local

and all i'm getting is this:
checking for mysql_close in -lmysqlclient... no
checking for mysql_error in -lmysqlclient... no
configure: error: mysql configure failed. Please check config.log for
more information.

this is what is going on in config.log:
/usr/bin/ld: skipping incompatible /usr/lib/mysql/libmysqlclient.so
when searching for -lmysqlclient
/usr/bin/ld: skipping incompatible /usr/lib/mysql/libmysqlclient.a
when searching for -lmysqlclient
/usr/bin/ld: cannot find -lmysqlclient

I've tried sooo many config combinations. config finishes if using
bundled mysql libs, but thats not enough... =(...

Any hope on this? Has anybody solved this before?

Thanks in advance!

# rpm -qa | grep mysql
mysql-5.0.45-7.el5
mysql-devel-5.0.45-7.el5
mysql-devel-5.0.45-7.el5
mysql-5.0.45-7.el5

--

Best Regards,

Ivan Levchenko
levchenko.i at gmail.com


More information about the CentOS mailing list