[CentOS] Update troubles for wxGTK apps

Nicolas Thierry-Mieg Nicolas.Thierry-Mieg at imag.fr
Tue Sep 23 07:12:12 UTC 2008



fred smith wrote:
> On Mon, Sep 22, 2008 at 08:19:37PM -0400, John wrote:
>> So what's the proper workaround here? As far as I'm concerned, Dag has
>> broken the update system on our Centos boxes. Is there any other way to
>> allow my system to be updated than to disable using Dag's repo?
>>
>> (not including removing Audacity--which I don't use a LOT, but I do use it.)
>>
>> ###################################################
>> JohnStanley Writes:
>>
>> Sure is, just use yum prioritys so when you do yum update it will exclude
>> "DAGS-Repo". Just follow the tutorial on wiki.centos.org.
> 
> I've had that set up ever since I first added any repositories.
> I've got it set to a priority of 10, is there a better value to use?

yum priority is for giving priority to one repo over another...
Totally irrelevant here, the the issues are rpmforge-only: the rf 
audacity needs GTK 2.6 while new builds of VLC and others (still rf) now 
need GTK 2.8.
Both GTK 2.6 and GTK 2.8 are available in rpmforge.
So, you have to choose your own priorities, no software can make the 
choice for you:
- either you upgrade GTK to 2.8, which requires uninstalling audacity 
(until some time in the probably not so distant future where Dag 
resolves the issues and manages to build audacity with GTK 2.8);
- or you stick to GTK 2.6, which means you have to keep your older 
versions of VLC and any other package whose newer versions were rebuilt 
with GTK 2.8.

Why is this such a big deal??

If it's really that critical to you, I'm sure Dag could use your help 
getting that audacity thing to build with GTK 2.8.


More information about the CentOS mailing list