[CentOS] Update troubles for wxGTK apps

John jses27 at gmail.com
Wed Sep 24 04:58:02 UTC 2008


-----Original Message-----
From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf
Of fred smith
Sent: Tuesday, September 23, 2008 7:57 PM
To: CentOS mailing list
Subject: Re: [CentOS] Update troubles for wxGTK apps

On Tue, Sep 23, 2008 at 09:12:12AM +0200, Nicolas Thierry-Mieg wrote:
> 
> 
> fred smith wrote:
> >On Mon, Sep 22, 2008 at 08:19:37PM -0400, John wrote:
> >>So what's the proper workaround here? As far as I'm concerned, Dag 
> >>has broken the update system on our Centos boxes. Is there any other 
> >>way to allow my system to be updated than to disable using Dag's repo?
> >>
> >>(not including removing Audacity--which I don't use a LOT, but I do 
> >>use
> >>it.)
> >>
> >>###################################################
> >>JohnStanley Writes:
> >>
> >>Sure is, just use yum prioritys so when you do yum update it will 
> >>exclude "DAGS-Repo". Just follow the tutorial on wiki.centos.org.
> >
> >I've had that set up ever since I first added any repositories.
> >I've got it set to a priority of 10, is there a better value to use?
> 
> yum priority is for giving priority to one repo over another...
> Totally irrelevant here, the the issues are rpmforge-only: the rf 
> audacity needs GTK 2.6 while new builds of VLC and others (still rf) 
> now need GTK 2.8.
> Both GTK 2.6 and GTK 2.8 are available in rpmforge.
> So, you have to choose your own priorities, no software can make the 
> choice for you:
> - either you upgrade GTK to 2.8, which requires uninstalling audacity 
> (until some time in the probably not so distant future where Dag 
> resolves the issues and manages to build audacity with GTK 2.8);
> - or you stick to GTK 2.6, which means you have to keep your older 
> versions of VLC and any other package whose newer versions were 
> rebuilt with GTK 2.8.
> 
> Why is this such a big deal??
> 
> If it's really that critical to you, I'm sure Dag could use your help 
> getting that audacity thing to build with GTK 2.8.

It's a big deal only in the sense that with a properly configured yum system
I cannot update my system without disabling a repository that wants to give
me incompatible updates, incompatible with itself.

I can certainly disable rpmforge, and as far as I can see that's my only
option here unless I want to mess around with audacity.
Somehow I was operating under the (apparent) delusion that the repo
maintainers would ensure they didn't create situations like this, so that
users wouldn't end up unable to update.

but if I don't want to do the devel work and especially if I was a user who
didn't know how to disable a repo, I'd be stuck here. So I asked if there
was any choice other than doing that. I've not heard that other people find
it to be an issue, so maybe I'm just overly sensitive, but it seems like a
breakage to me. What do I know.

I do not and did not mean to be offensive to Dag, and I apologize if I
was--it just seemed like an issue that would be affecting a lot more people
than just me and I wanted to see what others were doing about it.
So far I've not heard what that is.
----------------------------------------------------
JohnStanley Writes:

Now since you explain it in more detail. You have the option to compile from
source and build against gtk-2.8. Or B, yum update gtk then make a rpm -i
gtk /opt/ Install and link audacity against the Install in the /opt
Directory. Well, that basically sums up your options you have. I'm sure
there's other hacks to do this a better way.

Yea I can see a new user and this happening to them so I can see where your
coming from. I maybe wrong but you may want to check the man yum for setting
what package version to install for an rpm like foo_package1.0 and
foo_package.1.1. Could be wrong but maybe someone else can comment on that.
Don't think that is what you need either??

JohnStanley




More information about the CentOS mailing list