[CentOS] Upgrade

Michael A. Peters mpeters at mac.com
Thu Apr 2 02:30:57 UTC 2009


Thomas Dukes wrote:
> OK, here's a new one.
> 
> Changed all references in repo file to baseurl from mirror, ran yum clean
> all.
> 
> Now I get:
> 
> ERROR with rpm_check_debug vs depsolve:
> Package pyzor needs python-abi = 2.3, this is not available.
> 
> Of course, I ran yum install python-abi with no luck.
> 
> Something is broken.

The python in 5.3 is 2.4

pyzor is not in CentOS or EPEL.
Either the repo you got it from needs to update for python 2.4 or you 
need to try to get ahold of the source rpm, remove the package, yum 
update, and then rebuild the src.rpm against python 2.4

rpm -e pyzor

should remove it.


More information about the CentOS mailing list