[CentOS] yum update perl error in CentOS 5.3

Ralph Angenendt ra+centos at br-online.de
Fri Apr 3 12:37:55 UTC 2009


Olaf Mueller wrote:
>   File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 94, in
> _read_db_obj
>     setattr(self, item, _share_data(db_obj[item]))
> TypeError: unsubscriptable object

We're somehow seeing this error all over the place, which seems to be a
problem with multiarch. See bug http://bugs.centos.org/view.php?id=3486 and
the related ones plus https://bugzilla.redhat.com/show_bug.cgi?id=484728 - not
sure at the moment what is causing this.

Funny thing is that nobody got that during qa ...

One question: Your system has been updated to 5.3?

Ralph
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20090403/14a2e403/attachment.bin 


More information about the CentOS mailing list