[CentOS] Update from 5.2 to 5.3 kernel not on mirror

Rob Kampen rkampen at kampensonline.com
Tue Apr 7 22:28:46 UTC 2009



Blake Hudson wrote:
>
> -------- Original Message  --------
> Subject: Re: [CentOS] Update from 5.2 to 5.3 kernel not on mirror
> From: Michael Peterson <mpeterson at mail.charlesfurniture.com>
> To: CentOS mailing list <centos at centos.org>
> Date: Monday, April 06, 2009 4:02:36 PM
>> John R Pierce wrote:
>>   
>>> Michael Peterson wrote:
>>>   
>>>     
>>>> I have tried today and at least twice last week since the release of 5.3 
>>>> on Tuesday and got past the yum update glibc step just fine and have 
>>>> already done yum clean all several times and get through the first part 
>>>> of the yum update where you have to answer y and then it downloads all 
>>>> of the packages it seems but errors out and says that the kernel is not 
>>>> available on any mirrors.
>>>> The system is running 32 Bit CentOS 5.2.
>>>> It is a Pentium D system.
>>>> Has anyone else had this issue?
>>>> Is there a fix in progress for it?
>>>>   
>>>>     
>>>>       
>>> could you give the exact error message, also what kernel you're running 
>>> now, and any changes you may have made to /etc/yum.repos.d/* ?
>>>
>>> # uname -a
>>> Linux freescruz.com 2.6.18-92.1.18.el5 #1 SMP Wed Nov 12 09:30:27 EST 
>>> 2008 i686 i686 i386 GNU/Linux
>>> (note, we're intentionally running the prior kernel until my associate 
>>> can get around to rebuilding some audio kernel modules he requires)
>>>
>>> # yum list kernel\*
>>> Loaded plugins: fastestmirror, priorities
>>> Loading mirror speeds from cached hostfile
>>>  * epel: mirror.hmc.edu
>>>  * rpmforge: fr2.rpmfind.net
>>>  * base: centos.cogentcloud.com
>>>  * updates: mirror.stanford.edu
>>>  * addons: mirror.hmc.edu
>>>  * extras: www.cyberuse.com
>>> Excluding Packages from Red Hat Enterprise 5 - RPMforge.net - dag
>>> Finished
>>> Excluding Packages from CentOS-5 - Base
>>> Finished
>>> Excluding Packages from CentOS-5 - Updates
>>> Finished
>>> 1450 packages excluded due to repository priority protections
>>> Installed Packages
>>> kernel.i686                                                
>>> 2.6.18-92.1.18.el5                                     installed
>>> kernel.i686                                                
>>> 2.6.18-92.1.22.el5                                     installed
>>> kernel.i686                                                
>>> 2.6.18-128.1.6.el5                                     installed
>>> kernel-devel.i686                                          
>>> 2.6.18-92.1.18.el5                                     installed
>>> kernel-devel.i686                                          
>>> 2.6.18-92.1.22.el5                                     installed
>>> kernel-devel.i686                                          
>>> 2.6.18-128.1.6.el5                                     installed
>>> kernel-headers.i386                                        
>>> 2.6.18-128.1.6.el5                                     installed
>>> Available Packages
>>> kernel-PAE.i686                                            
>>> 2.6.18-128.1.6.el5                                     updates  
>>> kernel-PAE-devel.i686                                      
>>> 2.6.18-128.1.6.el5                                     updates  
>>> kernel-debug.i686                                          
>>> 2.6.18-128.1.6.el5                                     updates  
>>> kernel-debug-devel.i686                                    
>>> 2.6.18-128.1.6.el5                                     updates  
>>> kernel-doc.noarch                                          
>>> 2.6.18-128.1.6.el5                                     updates  
>>> kernel-xen.i686                                            
>>> 2.6.18-128.1.6.el5                                     updates  
>>> kernel-xen-devel.i686                                      
>>> 2.6.18-128.1.6.el5                                     updates  
>>> kerneloops.i386                                            
>>> 0.11-1.el5.rf                                          rpmforge
>>>
>>> _______________________________________________
>>> CentOS mailing list
>>> CentOS at centos.org
>>> http://lists.centos.org/mailman/listinfo/centos
>>>   
>>>     
>>
>> John
>>
>> I am also getting the error message on a Celeron 500 that has 5.2 that I 
>> am trying to update.
>>
>>  From the Celeron I have:
>>
>> The error message is:
>>
>> Error Downloading Packages:
>>  kernel - 2.6.18-128.1.6.el5.i686: failure: 
>> RPMS/kernel-2.6.18-128-1.6.el5.i686.rpm from updates: [Errno 256] No 
>> more mirrors to try.
>>
>> # uname --all
>> Linux router 2.6.18-92.el5 #1 SMP Tue Jun 10 18:49:47 EDT 2008 i686 i686 
>> i386 GNU/Linux
>>
>> # yum list kernel\*
>> Installed Packages
>> kernel.i686                              2.6.18-92.el5          installed
>> kernel-devel.i686                        2.6.18-92.el5          installed
>> kernel-headers.i386                      2.6.18-92.el5          installed
>> Available Packages
>> kernel.i686                              2.6.18-128.1.6.el5     updates
>> kernel-PAE.i686                          2.6.18-128.1.6.el5     updates
>> kernel-PAE-devel.i686                    2.6.18-128.1.6.el5     updates
>> kernel-debug.i686                        2.6.18-128.1.6.el5     updates
>> kernel-debug-devel.i686                  2.6.18-128.1.6.el5     updates
>> kernel-devel.i686                        2.6.18-128.1.6.el5     updates
>> kernel-doc.noarch                        2.6.18-128.1.6.el5     updates
>> kernel-headers.i386                      2.6.18-128.1.6.el5     updates
>> kernel-xen.i686                          2.6.18-128.1.6.el5     updates
>> kernel-xen-devel.i686                    2.6.18-128.1.6.el5     updates
>> #
>>
>> No change were made to repos on this system.
>>
>>  From the Pentium D I have:
>>
>> The error message is:
>>
>> Error Downloading Packages:
>>   kernel - 2.6.18-128.1.6.el5.i686: failure: 
>> RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm from updates: [Errno 256] No 
>> more mirrors to try.
>>
>> # uname --all
>> Linux storage.charlesfurniture.com 2.6.18-92.1.6.el5 #1 SMP Wed Jun 25 
>> 13:49:24 EDT 2008 i686 i686 i386 GNU/Linux
>>
>> # yum list kernel\*
>> Loading "fastestmirror" plugin
>> Loading mirror speeds from cached hostfile
>>  * base: mirrors.gigenet.com
>>  * updates: centos.mirror.nac.net
>>  * addons: mirror.steadfast.net
>>  * extras: mirror.icpl.org
>> Installed Packages
>> kernel.i686                              2.6.18-53.1.4.el5      installed
>> kernel.i686                              2.6.18-92.1.6.el5      installed
>> kernel.i686                              2.6.18-8.el5           installed
>> kernel-devel.i686                        2.6.18-53.1.4.el5      installed
>> kernel-devel.i686                        2.6.18-8.el5           installed
>> kernel-devel.i686                        2.6.18-92.1.6.el5      installed
>> kernel-headers.i386                      2.6.18-92.1.6.el5      installed
>> Available Packages
>> kernel.i686                              2.6.18-128.1.6.el5     updates
>> kernel-PAE.i686                          2.6.18-128.1.6.el5     updates
>> kernel-PAE-devel.i686                    2.6.18-128.1.6.el5     updates
>> kernel-debug.i686                        2.6.18-128.1.6.el5     updates
>> kernel-debug-devel.i686                  2.6.18-128.1.6.el5     updates
>> kernel-devel.i686                        2.6.18-128.1.6.el5     updates
>> kernel-doc.noarch                        2.6.18-128.1.6.el5     updates
>> kernel-headers.i386                      2.6.18-128.1.6.el5     updates
>> kernel-xen.i686                          2.6.18-128.1.6.el5     updates
>> kernel-xen-devel.i686                    2.6.18-128.1.6.el5     updates
>>
>>
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> http://lists.centos.org/mailman/listinfo/centos
>>   
> I have a similar problem. Dual PIII Dell server.
>
> Following the directions to upgrade from 5.2 -> 5.3. I ran "yum clean 
> all" and "yum update glibc" successfully. Though when trying to do a 
> yum upgrade I receive the following errors:
>
> --------------------
> yum upgrade
> ... snip...
>
> (174/260): kernel-2.6.18- 100% |=========================|  15 MB    
> 00:21    
> http://centos.mirror.nac.net/5.3/updates/i386/RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm: 
> [Errno -1] Package does not match intended download
> Trying other mirror.
> http://ftp.lug.udel.edu/pub/centos/5.3/updates/i386/RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm: 
> [Errno 9] Requested Range Not Satisfiable
> Trying other mirror.
> http://mirror.stanford.edu/yum/pub/centos/5.3/updates/i386/RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm: 
> [Errno 9] Requested Range Not Satisfiable
> Trying other mirror.
> http://mirror.newnanutilities.org/pub/centos/5.3/updates/i386/RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm: 
> [Errno 9] Requested Range Not Satisfiable
> Trying other mirror.
> http://mirrors.rit.edu/centos/5.3/updates/i386/RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm: 
> [Errno 9] Requested Range Not Satisfiable
> Trying other mirror.
> http://mirrors.usc.edu/pub/linux/distributions/centos/5.3/updates/i386/RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm: 
> [Errno 9] Requested Range Not Satisfiable
> Trying other mirror.
>
> .. snip...
>
> Error Downloading Packages:
>   kernel - 2.6.18-128.1.6.el5.i686: failure: 
> RPMS/kernel-2.6.18-128.1.6.el5.i686.rpm from updates: [Errno 256] No 
> more mirrors to try.
> --------------------
>
> I'm currently on kernel 2.6.18-92.1.6.el5
>
>
> I had no problem upgrading two recent installs, but this is an older 
> install that I do not update as regularly.
>
> --Blake
> ------------------------------------------------------------------------
>
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
>   
Interesting.....I thought that i686 used instructions only available on 
later processors, i.e. i486 and pentium III do not have the later 
instruction set to accept compiled code for i686.....
I'm no expert, but that is why there are i386, i686 and x86_64 type 
packages to cater for various processor types.
HTH
-------------- next part --------------
A non-text attachment was scrubbed...
Name: rkampen.vcf
Type: text/x-vcard
Size: 128 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20090407/c9e00e51/attachment.vcf 


More information about the CentOS mailing list