[CentOS] CentOS 5.3 samba: getent does not return data from the active directory (ads)

JohnS jses27 at gmail.com
Tue Apr 7 23:39:29 UTC 2009


On Tue, 2009-04-07 at 16:47 -0500, Jason Ellison wrote:
> On Tue, Apr 7, 2009 at 4:17 PM, JohnS <jses27 at gmail.com> wrote:
> >
> > On Tue, 2009-04-07 at 15:33 -0500, Jason Ellison wrote:
> >
> > By the way looking again:
> >
> >> ("getent passwd" command issued)
> >
> > Should be "getent passwd | grep user_name"
> 
> JohnS,
> 
>   Why are you suggesting I filter the output of getent?  What does
> this have to do with getent retrieving information from the active
> directory?  Please help me understand you logic here...  also I would
> like to know the following:

Why? Why not? Has a lot to do with it when you don't have winbindd
working right to enumerate. Also it would be the correct way in doing
so. Either way is correct and getent doesn't make windbind work.
> 1) are you using samba
I use it every day. Even with samba-vfs module. Just not with Server
2008 AD.
> 2) is your server a memeber of the active directory?
Would it make sense for it to be if it's in a totaly Windows Controled
Domain? Yes
> 3) are you using winbind via nsswitch so local utilities can enumerate
> users and groups from the active directory?
If there is a way around using nsswitch then inform me of it. Every AD
config for samba adds a change to nsswitch that I am aware of.

How is your samba config file. Also, I am not aware of wbinfo working
with out being a member server which you would have to "net ads join -U
admin". For 2003 the samba config is different than a 2000 AD Controler
config. That is in the [globals] section.



More information about the CentOS mailing list