[CentOS] FYI: solution Re: mock %post(pam) failure

Farkas Levente lfarkas at lfarkas.org
Tue Apr 14 13:29:32 UTC 2009


Farkas Levente wrote:
> Karanbir Singh wrote:
>> On 04/13/2009 04:43 PM, Rex Dieter wrote:
>>>> Well, I heard from one of the CentOS devs that mock newer than 0.6 was
>>>> broken.
>>> OK, fair 'nuf.  Just seemed silly to me that you'd assume epel would release
>>> something that was broken.
>> EPEL releases broken stuff all the time :)
>>
>> Also mock > 0.6 doesnt work properly on c3/c4 - and mock 0.9.x is 
>> different enough to produce inconsistent builds with mock 0.6, which is 
>> why were sticking to mock 0.6 for the time being, within CentOS.
> 
> on centos-5.2 mock-0.9.x was working properly. now neither mock not even
> rpmbuild working for us (this second is another probably rpm bug which
> is just investigating).
> anyway you suggest to use mock 0.6 on 5.3?
> thanks.

it turns out as we downgrade to 5.2's rpm*, popt packages both our
rpmbuild problem and mock-0.9.x problems goes away. so it seems there
is/are some kind of rpm bug in 5.3.

-- 
  Levente                               "Si vis pacem para bellum!"


More information about the CentOS mailing list