[CentOS] httpd crashes after signal HUP

Per Qvindesland per at norhex.com
Sun Apr 19 08:59:54 UTC 2009


Have you tried this:
http://www.electrictoolbox.com/seg-fault-or-similar-nasty-error/

Per

--- Original message follows ---
SUBJECT: Re: [CentOS] httpd crashes after signal HUP
FROM:  "RedShift" 
TO: "CentOS mailing list" 
DATE: 19-04-2009 9:49

>----- Oorspronkelijk bericht -----
>Van
: RedShift [mailto:redshift at pandora.be]
>Verzonden
: zondag
, april
19, 2009 09:42 AM
>Aan
: centos at centos.org
>Onderwerp
: [CentOS] httpd crashes after signal HUP
>

>Hello
>
>
>I'm running CentOS 5.3 with httpd-2.2.3-22.el5.centos.x86_64 and
php-5.1.6-23.2.el5_3.x86_64. When the logrotate scripts run and send
the HUP signal to httpd, the httpd process quits instead of reloading.
The only thing I can find in the logs is this:
>
>[Sun Apr 19 04:02:04 2009] [notice] seg fault or similar nasty error
detected in the parent process
>
>There wasn't any segfault reported in dmesg and I couldn't find
anything else in the other logs (messages, etc...)
>
>It's reproducable every time, when I send the HUP signal to the
master httpd process the same thing happens.
>
>My configuration is nothing special, just the stock one, with a few
unnecesary modules commented out and one virtual host.
>

A follow-up, I cannot seem to reproduce this on my laptop (using i386
instead of x86_64) with the same configuration.

Glenn

_______________________________________________
CentOS mailing list
CentOS at centos.org
http://lists.centos.org/mailman/listinfo/centos
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20090419/0150ee75/attachment.html 


More information about the CentOS mailing list