[CentOS] X won't start

Robert kerplop at sbcglobal.net
Sun Apr 19 18:25:28 UTC 2009


This machine is running CentOS 5.3, fully updated Linux 
mavis.localdomain 2.6.18-128.1.6.el5 #1
SMP Wed Apr 1 09:19:18 EDT 2009 i686 athlon i386 GNU/Linux. Video is an 
ATI Radeon 9000.
X froze overnight and attempts to restart it fail.  I tried an old 
kernel (2.6.18-92.1.22.el5)
before realizing that root can start X and a virgin user can start X. I 
still can't use my
original user name.  I'm sure the last line of this is telling me 
something that I'm missing.

    (**) RADEON(0): RADEONDRIStop
    (**) RADEON(0): EngineRestore (16/16)
    (**) RADEON(0): RADEONDisplayPowerManagementSet(0,0x0)
    (**) RADEON(0): RADEONRestore
    (**) RADEON(0): RADEONRestoreMode()
    (**) RADEON(0): RADEONRestoreMode(0x9d2831c)
    (**) RADEON(0): RADEONRestoreMemMapRegisters() :
    (**) RADEON(0):   MC_FB_LOCATION   : 0x1fff0000
    (**) RADEON(0):   MC_AGP_LOCATION  : 0x27ff2000
    (**) RADEON(0):   Map Changed ! Applying ...
    (**) RADEON(0):   Map applied, resetting engine ...
    (**) RADEON(0): Updating display base addresses...
    (**) RADEON(0): Memory map updated.
    (**) RADEON(0): Programming CRTC1, offset: 0x00000000
    (**) RADEON(0): Wrote: 0x0000000c 0x00030065 0x00000000 (0x0000a400)
    (**) RADEON(0): Wrote: rd=12, fd=101, pd=3
    (**) RADEON(0): Disposing accel...
    (**) RADEON(0): Disposing cusor info
    (**) RADEON(0): Disposing DGA
    (**) RADEON(0): Unmapping memory
    (**) RADEON(0): RADEONDRICloseScreen
    FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing.

If it matters I normally boot into run level 3, log in and issue
"startx" from the BASH prompt.

Any ideas welcome.




More information about the CentOS mailing list