[CentOS] rpmbuild failure

lhecking at users.sourceforge.net lhecking at users.sourceforge.net
Mon Apr 20 11:06:26 UTC 2009


lhecking at users.sourceforge.net writes:
> 
>  I'm trying to rebuild nx-3.2.0-8.el5.centos.src.rpm from the extras repo.
>  It works on a machine running 5.1, but fails on another running 5.3. The
>  working machine is arch=x86_64, the other i386. The strange bit is the line
>  rpmbuild complains about: it's the last line in the spec file, at the end
>  of the %changelog section:
> 
> [...]
> Processing files: nx-debuginfo-3.2.0-8
> Finding  Provides: /usr/src/redhat/SOURCES/nxfind-provides.sh
> error: line 352: Dependency tokens must begin with alpha-numeric, '_' or '/': - Updated SuSE package to work with Fedora
> 
> error: Failed to find Provides:
> Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
> Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/nx-3.2.0-8-root-root
> 
> 
> RPM build errors:
>     line 352: Dependency tokens must begin with alpha-numeric, '_' or '/': - Updated SuSE package to work with Fedora
> 
>     Failed to find Provides:
> # 

 Checking on CentOS5.2/i386: rpms are being built despite errors.

[...]
Processing files: nx-debuginfo-3.2.0-8.el5.centos
Finding  Provides: /usr/src/redhat/SOURCES/nxfind-provides.sh
error: line 352: Dependency tokens must begin with alpha-numeric, '_' or '/': - Updated SuSE package to work with Fedora

error: Failed to find Provides:
Provides: libXcompext.so.3.2.0.debug libXcompshad.so.3.2.0.debug libXcomp.so.3.2.0.debug
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(CompressedFileNames) <= 3.0.4-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/nx-3.2.0-8.el5.centos-root-root
Wrote: /usr/src/redhat/SRPMS/nx-3.2.0-8.el5.centos.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/nx-3.2.0-8.el5.centos.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/nx-debuginfo-3.2.0-8.el5.centos.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.10397
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nx-3.2.0
+ rm -rf /var/tmp/nx-3.2.0-8.el5.centos-root-root
+ exit 0

 So, 5.1 and 5.2 work, 5.3 doesn't. What's going on? Stricter spec file
 checking?




More information about the CentOS mailing list