[CentOS] php-mcrypt from c5-testing is the wrong version

Joe Pruett joey at clean.q7.com
Tue Apr 28 05:56:49 UTC 2009


> I am using the c5-testing repo to fetch PHP 5.2.6 and related
> libraries, required for the LAMP apps that I want to use. php-mcrypt
> still seems to come from the extras repo and is version 5.1.6 and the
> php binary doesn't load this module.
>
> Any ideas on howto get php-mcrypt 5.2.6?

as i was waiting for the c5-testing repo to catch up with redhat, i went 
ahead and built my own.  i had to take the php-extras rpm and merge the 
php changes between 5.1.6 and 5.2.6 into it.  and to get mock to be happy 
i had to add the normal extras repo into the mock config so that the 
mcrypt libraries were there.

i hesitate to make my repo public, but i know it is possible to make a new 
php-mcrypt based on the upstream code.


More information about the CentOS mailing list