[CentOS] 5.3 on an EeePC??

Fabian Arrotin fabian.arrotin at arrfab.net
Tue Apr 28 19:15:32 UTC 2009


Beartooth wrote:
> 	I have an ASUS EeePC 701 (with 2GB of RAM and an 8 GB card), on 
> which I've installed CentOS on the hard-drive-plus-card. But it can't 
> even use my eth0.
> 
>    Some one on a local LUG, where I had mentioned that other OSs did fine 
> with all the same exact hardware, suggested that CentOS, being designed 
> for stability rather than the bleeding edge, likely lacks drivers; so I 
> need to get some.
> 
>    Anybody know what drivers (for wireless as well as ethernet cable) I 
> need, and how/where to get ones to fit CentOS??
>

I wrote a page on the Wiki regarding CentOS 5.2 on the Eee PC (was a 900 
model though) : http://wiki.centos.org/HowTos/Laptops/Asus/Eeepc
But i admit also that i've not yet updated the page for 5.3 (and neither 
created a modified initrd.img to include the atl2 kernel module) .. I've 
updated my 5.2 Eee PC to 5.3 and everything was still working as 
expected ... it even removed the (previously needed) uvcvideo kernel 
module, now included in the base kernel.

On the other hand, I also admit that i was tempted by F10 on the same 
machine to compare boot performance and we have to admit also that the 
2.6.18-*.el5 kernel was surely not designed to be used on netbook : F10 
boots faster and of course has by default everything needed (atl2, 
madwifi for the Atheros wifi card, newer alsa module for the sound card, 
better acpi support, etc ...)

So running CentOS on the Eee PC is doable and everything is working 
(wired/wifi/webcam/suspend/hibernate) but real slow in comparison with 
F10 .. :/

-- 
--
Fabian Arrotin
  idea=`grep -i clue /dev/brain`
  test -z "$idea" && echo "sorry, init 6 in progress" || sh ./answer.sh


More information about the CentOS mailing list