[CentOS] libvirt 0.7.4 for Centos 5.4

Mr. X tlviewer at yahoo.com
Tue Dec 15 22:21:24 UTC 2009


Albert,

--- On Tue, 12/15/09, Albert <forall at stalowka.info> wrote:

> From: Albert <forall at stalowka.info>
> Subject: [CentOS] libvirt 0.7.4 for Centos 5.4
> To: centos at centos.org
> Date: Tuesday, December 15, 2009, 1:33 PM
> Hi,
> 
> It's exist any repo where I find a newer libvirt-0.7.4 for
> Centos 
> 5.4_x86_64?
> 
> For at ll

It is from FC13.
---------------- history -----------
wget ftp://ftp.pbone.net/mirror/download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/libvirt-0.7.4-1.fc13.src.rpm
history | grep rpmbuild
rpmbuild --rebuild --sign --define 'dist .el5' libvirt-0.7.4-1.fc13.src.rpm
man rpmbuild
// fc13 now uses sha256 sigs, so do a workaround
sudo rpm -i --nomd5 libvirt-0.7.4-1.fc13.src.rpm
ls -l ./redhat/SPECS/
rpmbuild -ba ./redhat/SPECS/libvirt.spec
history | tail
// bad news
error: Failed build dependencies:
        xen-devel is needed by libvirt-0.7.4-1.x86_64
        xmlrpc-c-devel >= 1.14.0 is needed by libvirt-0.7.4-1.x86_64
        xhtml1-dtds is needed by libvirt-0.7.4-1.x86_64
        gnutls-devel is needed by libvirt-0.7.4-1.x86_64
        cyrus-sasl-devel is needed by libvirt-0.7.4-1.x86_64
        parted-devel is needed by libvirt-0.7.4-1.x86_64
        device-mapper-devel is needed by libvirt-0.7.4-1.x86_64
        libssh2-devel is needed by libvirt-0.7.4-1.x86_64
-------------------- end snip -------

AFAIK, you don't want to go here and try this any further since you
need the device-mapper-devel from FC13.

Maybe someone else will show how to get around that!

-- 
Mark

my Phronix Test Suite Page for C5.4
http://www.tlviewer.org/pts/


      


More information about the CentOS mailing list